Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#4852 closed defect (invalid)

Cannot access web interface for Transterpreter.

Reported by: anonymous Owned by: Jonas Borgström
Priority: high Milestone:
Component: general Version: 0.10.3.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Emmanuel Blot)

Here's the Python traceback for accessing transterpreter.org. Also unable to access Subversion repository.

Python Traceback

Traceback (most recent call last):
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/web/main.py", line 191, in dispatch
    chosen_handler = self._pre_process_request(req, chosen_handler)
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/web/main.py", line 263, in _pre_process_request
    chosen_handler = f.pre_process_request(req, chosen_handler)
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/versioncontrol/api.py", line 73, in pre_process_request
    self.get_repository(req.authname) # triggers a sync if applicable
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/versioncontrol/api.py", line 101, in get_repository
    repos = self._connector.get_repository(rtype, rdir, authname)
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 259, in get_repository
    repos = SubversionRepository(dir, None, self.log)
  File "/usr/local/trac-0.10.3/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 292, in __init__
    self.repos = repos.svn_repos_open(self.path, self.pool())
SubversionException: ("Berkeley DB error while opening 'revisions' table for filesystem /data/svn/transterpreter/db:\nCannot allocate memory", 160029)

Attachments (0)

Change History (4)

comment:1 by Emmanuel Blot, 15 years ago

Description: modified (diff)
Resolution: invalid
Status: newclosed
Version: 0.10.3

This is an out of memory condition.

Please report the issue to the http://trac.transterpreter.org/ web site administrator.
BTW, use of BerkeleyDB backend for Subversion is not recommended with Trac.

comment:2 by Br0th3r, 15 years ago

Priority: normalhigh
Resolution: invalid
Severity: normalblocker
Status: closedreopened
Version: 0.10.30.10.3.1

Anyway, why not recommended? not recommended means "I shouldn't use it because will be failing all the time"?, how to repair it?, I see this error closed but no solution for it. :m

comment:3 by Emmanuel Blot, 15 years ago

Resolution: invalid
Severity: blockernormal
Status: reopenedclosed

First, be fair with the ticket fields (severity, for example).

This is not an issue that prevents from using Trac, please contact the web admin that manages this specific Trac installation.

comment:4 by Emmanuel Blot, 15 years ago

BTW, this looks like a duplicate of #4121.

BerkeleyDB backend for Subversion is not recommended with Trac as several issues have been found with this backend. You can search for "berkeley" in the Trac ticket database to find the exact issue descriptions, as well as TracSubversion#TracandSubversion1.1

FSFS is the recommended backend for Subversion (this is the default backend when you initialize a repository) and I think it could be considered as "highly recommended" to use with Trac.

To convert a repository from BDB to FSFS, see http://subversion.tigris.org/faq.html#bdb-fsfs-convert

Additional note about my previous comment: blocker means that Trac (the software) cannot be used at all.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.