Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#4828 closed defect (duplicate)

Couldn't login or reset password

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

I was trying to login to trac.adiumx.com, and it wouldn't let me login with the password I knew was correct. But in any case, I decided that I would tell it to reset my password, so I entered my name and email address (theosib, theosib@…), and I got this result:

Oops… Trac detected an internal error: If you think this really should work and you can reproduce it, you should consider reporting this problem to the Trac team.

Go to http://trac.edgewall.org/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the Python traceback found below.

TracGuide — The Trac User and Administration Guide

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 156, in process_request
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 195, in _do_reset_password
  File "build/bdist.linux-i686/egg/acct_mgr/api.py", line 98, in set_password
  File "build/bdist.linux-i686/egg/acct_mgr/htfile.py", line 70, in set_password
  File "build/bdist.linux-i686/egg/acct_mgr/htfile.py", line 104, in _update_file
  File "/usr/local/lib/python2.4/fileinput.py", line 101, in input
    raise RuntimeError, "input() already active"
RuntimeError: input() already active

If I click the back button, and try again, I always get the same error.

The URL where I click "reset" is "http://trac.adiumx.com/reset_password", and it's that same URL that I see when I get the above error.

Attachments (0)

Change History (1)

comment:1 by Emmanuel Blot, 13 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #4801, #4810 and #4816.

I really hope the web admin at adiumx.com fixes this issue soon ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.