Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#4630 closed defect (fixed)

Flaw in ticket assignee list

Reported by: Emmanuel Blot Owned by: Eli Carter
Priority: highest Milestone: 0.11
Component: ticket system Version: devel
Severity: major Keywords: permission
Cc: Branch:
Release Notes:
API Changes:

Description

I just bumped into an issue which looks like a regression (since the upgrade to Trac trunk from 0.10.3, using r4665):

The drop-down list used to assign an owner to a ticket is not filled as (I) expected. Only a few names among all the users registered on the system appear in the drop-down list.

The drop-down list content is built from the list of users that own the TICKET_MODIFY permission.

When the TICKET_MODIFY permission is only set for the special authenticated user, it seems that the list is not populated - w/ the exception of the users that own 'parent' permissions, for example the list of the administrators as TRAC_ADMIN permission leads to grant TICKET_MODIFY permission.

Many others have already been authenticated on the system:

select * from session where authenticated=='1';

reports 34 users.

Additional comment from cboos:

This is likely a regression introduced by [4625]

Attachments (0)

Change History (9)

comment:1 by Christian Boos, 12 years ago

Keywords: permission added
Priority: normalhigh
Severity: normalmajor

Confirmed by #5328.

comment:2 by Emmanuel Blot, 12 years ago

Priority: highhighest
Severity: majorcritical

Increasing the priority, as this should be fixed for 0.11

#5616 marked as another duplicate

comment:3 by Emmanuel Blot, 12 years ago

Severity: criticalmajor

comment:4 by Christian Boos, 12 years ago

Milestone: 0.11.10.11
Owner: Jonas Borgström removed

If either cmlenz or athomas could have a look… Thanks!

comment:5 by anonymous, 12 years ago

#5689 looks like another duplicate.

comment:6 by Kenneth Xu <kennethxu@…>, 12 years ago

FYI, I have users in 'poweruser' group, which has TRAC_ADMIN right. They are listed in the drop down. But other authenticated users with TRAC_MODIFY are not.

comment:7 by Eli Carter, 12 years ago

Resolution: fixed
Status: newclosed

cboos is right, this is a regression from [4625]. The problem is that the optimized code did not take 'authenticated' into account.

Fixed using a brute-force inefficient solution in [5849], and I will reopen #4245.

comment:8 by Christian Boos, 12 years ago

Keywords: fixowner added

comment:9 by Christian Boos, 10 years ago

Keywords: fixowner removed
Owner: set to Eli Carter

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Eli Carter.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.