Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

#4551 closed defect (worksforme)

Problem in access section plugins in webadmin.

Reported by: anonymous Owned by: Christopher Lenz
Priority: normal Milestone:
Component: admin/web Version: 0.10.3
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Tim Hatch)

Problem in access section plugins in webadmin.

Python Traceback

Traceback (most recent call last):
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "c:\python23\lib\site-packages\TracWebAdmin-0.1.1dev_r2765-py2.3.egg\webadmin\web_ui.py", line 106, in process_request
    path_info)
  File "c:\python23\lib\site-packages\TracWebAdmin-0.1.1dev_r2765-py2.3.egg\webadmin\plugin.py", line 76, in process_admin_request
    self._render_view(req)
  File "c:\python23\lib\site-packages\TracWebAdmin-0.1.1dev_r2765-py2.3.egg\webadmin\plugin.py", line 157, in _render_view
    if os.path.realpath(os.path.dirname(dist.location)) == plugins_dir:
AttributeError: 'NoneType' object has no attribute 'location'

Attachments (0)

Change History (5)

comment:1 by Tim Hatch, 16 years ago

Description: modified (diff)
Keywords: needinfo added

If you're indeed using Trac 0.10.3, r2765 is too old to work. Check the table of versions on WebAdmin and make sure you're using the proper one.

comment:2 by mark.m.mcmahon@…, 16 years ago

I was getting the same error today (on 10.0) and it seemed to be caused by a py file in the plugins directory.

If the plugins directory was empty - Webadmin\Plugins worked fine If there was a folder with an init.py - it worked fine If there was a py in the root of plugins - then I got this problem.

comment:3 by mark.m.mcmahon@…, 16 years ago

Actually not sure if the middle of my comments above is correct (directory with init.py file) - though this is on a production server and I can't keep restarting the server to check again.

comment:4 by sid, 15 years ago

Did you upgrade WebAdmin to the newer version? If so, did that fix your issue?

comment:5 by Christian Boos, 15 years ago

Milestone: not applicable
Resolution: worksforme
Status: newclosed

Assuming upgrade has worked.

In any case, when having problems with WebAdmin, one should really consider upgrading to 0.11.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.