Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#452 closed defect (fixed)

bad-formatted e-mail notification

Reported by: anonymous Owned by: Jonas Borgström
Priority: high Milestone: 0.8
Component: general Version: devel
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I just updated from Trunk… You can see that top part of e-mail is not looking goood. Below is example of bad-formatted e-mail notification:


#926: Rx Ring desing and implementation——————————————————-+——————————————————— Id: 926 | Status: new Component: HAL | Modified: Fri May 21 09:51:05 2004 Severity: normal | Milestone: 2.0 Priority: P1 | Version: 1.0 Owner: dmitry@xxxx | Reporter: dmitry@xxxxx——————————————————-+———————————————————As above

keys:

  • port steering
  • optimized locking
  • include smart pool-based memory management
  • incapsulation into HAL channel abstraction
  • Ring statistics
  • MSI if available

Dmitry

Attachments (0)

Change History (6)

comment:1 by Jonas Borgström, 15 years ago

Can you submit the example again and this time inside a code block like this:

{{{
In here
}}}

Or as a screenshot?

comment:2 by daniel, 15 years ago

Milestone: 0.7.1
Priority: normalhigh
Severity: normalmajor

comment:3 by anonymous, 15 years ago

Here it is:

#926: Rx Ring desing and implementation-------------------------------------+--------------------------------------       Id:  926                      |      Status:  new                     Component:  HAL                      |    Modified:  Fri May 21 09:51:05 2004 Severity:  normal                   |   Milestone:  2.0                      Priority:  P1                       |     Version:  1.0                         Owner:  dmitry@xxxx  |    Reporter:  dmitry@xxxx -------------------------------------+--------------------------------------As above

keys:

    * port steering
    * optimized locking
    * include smart pool-based memory management
    * incapsulation into HAL channel abstraction
    * Ring statistics 
    * MSI if available



-- Ticket URL: <http://10.16.16.227/cgi-bin/trac.cgi/ticket/926>xxx <http://trac.edgewall.com/>

comment:4 by daniel, 15 years ago

Resolution: fixed
Status: newclosed

I'm unable to reproduce this. However, notification now uses os.linesep instead of '\n' in emails. Possibly, this will fix your problem.

Fixed in [668].

comment:5 by anonymous, 15 years ago

Milestone: 0.7.10.8
Resolution: fixed
Status: closedreopened

still the same behavior with 0.7.1 environment: RedHat 9.0/sendmail

comment:6 by daniel, 15 years ago

Resolution: fixed
Status: reopenedclosed

[740] changes emails so all lines are terminated by CRLF rather than os.linesep.

This ought to fix the problem.

If not, please attach a sample problematic email to this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.