Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#4413 closed defect (duplicate)

don't expose email address

Reported by: Waldemar Kornewald <wkornewald> Owned by: Jonas Borgström
Priority: high Milestone:
Component: general Version: devel
Severity: normal Keywords:
Cc: wkornewald Branch:
Release Notes:
API Changes:

Description

Many users want to keep their email address private. Trac exposes the email address of all registered users which could be a reason for some people to not report a bug. Even if the developers don't care it should still be cared about the bug reporters (users).

Attachments (1)

privacy.diff (8.0 KB ) - added by Waldemar Kornewald <wkornewald> 13 years ago.
patch against trunk (r4456)

Download all attachments as: .zip

Change History (4)

by Waldemar Kornewald <wkornewald>, 13 years ago

Attachment: privacy.diff added

patch against trunk (r4456)

comment:1 by Waldemar Kornewald <wkornewald>, 13 years ago

The patch also fixes a bug where two empty entries are shown in "Assign to" when restrict_owner is enabled.

I must admit, I haven't had the time to test it yet, but the changes are pretty simple.

comment:2 by Emmanuel Blot, 13 years ago

Resolution: duplicate
Status: newclosed

Please search for existing tickets before submitting new ones.

This is a duplicate of #153, #1448.

The patch cannot be directly applied as the email address obusfcation should be an option, not an obligation.

comment:3 by Christian Boos, 12 years ago

Milestone: 0.11

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.