Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#4281 closed defect (wontfix)

Notifications should be sent only after attachment is uploaded

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.10.2
Severity: major Keywords: notification attachment
Cc: Branch:
Release Notes:
API Changes:

Description

…or after a certain timeout if the user doesn't go through with uploading it.

Otherwise, especially if it may take a long time to upload the attachment, a notified user may view the ticket in a half baked state.

Attachments (0)

Change History (2)

in reply to:  description comment:1 by Emmanuel Blot, 13 years ago

Component: generalticket system
Keywords: notification attachment added
Priority: highnormal
Severity: normalmajor

Replying to anonymous:

…or after a certain timeout if the user doesn't go through with uploading it.

Notification are synchronous with web requests, so there is no way a time out can be used.

I think this could be considered as a potential duplicate of another ticket: #2259, which requests that a notification is emitted when a file is attached to a ticket.

I'm not sure that delaying the first notification to the attachment completion is reliable enough, I would therefore vote for "duplicate" here.

comment:2 by Christian Boos, 13 years ago

Resolution: wontfix
Status: newclosed

There's no notification sent after an attachment upload (that would be feature request #2259), so I assume you're talking about ticket creation notification.

A ticket gets created right away, even if you select the I have files to attach to this ticket checkbox. By doing that, you simply go automatically to the create attachment page after the ticket has been created, and there's no way we could delay the ticket creation notification to after that second step, which is not bound to ever complete.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.