Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4272 closed defect (wontfix)

Available Reports page always asks if I want to delete "this report"

Reported by: akaihola Owned by: Matthew Good
Priority: normal Milestone:
Component: report system Version: devel
Severity: normal Keywords: genshi
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

At revision 4353, when clicking "View Tickets", the URL <project-url>/report is opened, and it always begins with the question "Are you sure you want to delete this report?" with "Cancel" and "Delete report" buttons.

Here's a snippet from the HTML source:

    <div id="main">
    <div id="ctxtnav" class="nav">
      <h2>Report Navigation</h2>
      <ul>
        <li class="first">
          Available Reports
        </li>

        <li class="last"><a href="/taiteilijat/query">Custom Query</a></li>
      </ul>
    </div>
        <h1>Available Reports
        <form action="/taiteilijat/report" method="post"><div><input type="hidden" name="__FORM_TOKEN" value="941c2efbfe73d9267dc2eb76" /></div>
        <input type="hidden" name="id" value="-1">
        <input type="hidden" name="action" value="delete">
        <p><strong>Are you sure you want to delete this report?
        <div class="buttons">

          <input type="submit" name="cancel" value="Cancel">
          <input type="submit" value="Delete report">
    <div id="content" class="report">
  <h1>Available Reports
  </h1>
  <div id="description"><p>
This is a list of available reports.
</p>
</div>
    <table class="listing reports">

Attachments (1)

report-delete.diff (1.7 KB ) - added by akaihola 14 years ago.
Wild guess how to fix this.

Download all attachments as: .zip

Change History (6)

by akaihola, 14 years ago

Attachment: report-delete.diff added

Wild guess how to fix this.

comment:1 by akaihola, 14 years ago

It seems that the <xi:fallback> was evaluated even when $action == 'view' and report_view.html was successfully included. Genshi bug?

comment:2 by akaihola, 14 years ago

Also, inside the fallback, the closing </h1> tag was not output, no matter what I tried. Another Genshi bug?

comment:3 by Tim Hatch <trac@…>, 14 years ago

Keywords: needinfo added

I agree that looks weird, however I can't reproduce it with Genshi trunk. Can you give a little more information?

  1. what version of Genshi are you running?
  2. how are you running Trac? (cgi, mod_python, etc)
  3. are your template directories set up correctly, with permissions too?

comment:4 by Christian Boos, 14 years ago

Keywords: genshi added; needinfo removed
Resolution: wontfix
Status: newclosed

This is a Genshi bug, see #G80, which has a patch.

external resolution ;)

comment:5 by Christian Boos, 14 years ago

(for info, it's now fixed in [Genshi 463/trunk])

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.