Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#4271 closed defect (wontfix)

All timestamp related fields return today's date (ie time, changetime)

Reported by: lawrielo@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: timeline Version: 0.9.6
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi,

I have been using trac for over 6 months and had not encountered any problems until today. For some reason all of the date's displayed for tickets created, some of which were created several month's ago have changed to today's date. The ticket history at the top right hand corner of the ticket is correct but the logs under the ticket are all showing today's date. The events displayed in the timeline also show all of today's date too. Can anyone explain to me what would have corrupted the pysqlite database to only return today's date for all time fields?

Regards,

Attachments (0)

Change History (8)

comment:1 by Christian Boos, 14 years ago

Can you have a direct look in the database using the sqlite3 command-line tool?

e.g. do select id, time from ticket.

Is this problem limited to tickets, or are the other resources affected as well?

comment:2 by Matthew Good, 14 years ago

Keywords: needinfo added

comment:3 by lawrielo@…, 14 years ago

I did what you suggested and it returns 44 ids (which is the same amount as the number of tickets), and the time is all today's date.

Other resources are affected too.

Thanks.

comment:4 by Matthew Good, 14 years ago

Has anyone been running any database queries on Trac? Maybe they accidentally ran an update query on the tickets and updated the time. Are you using any scripts or plugins with Trac? Which ones? Maybe there's a bug in one of these that's updated the time of all the tickets.

comment:5 by lawrielo@…, 14 years ago

I'm only using the repository search plugin to allow users to include the subversion repository in their searches. I have removed the plugin and have still noticed that the timestamps of all items in trac change whenever i refresh the trac timeline page. I think that is the problem. Is there a fix for this?

comment:6 by Lawrence Lo <lawrielo@…>, 14 years ago

Severity: normalmajor

comment:7 by Christian Boos, 14 years ago

Any follow-up on this? Otherwise we'll close the ticket as wontfix, since no one else ever saw this issue, nor do I see how it could happen in normal circumstances.

comment:8 by Christian Boos, 14 years ago

Keywords: needinfo removed
Resolution: wontfix
Status: newclosed

Nobody was able to reproduce that error, and I don't see how we could help here.

A guess which is worth any other, it could have been a modified trac-post-commit-hook which was misbehaving…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.