Edgewall Software
Modify

Opened 13 years ago

Closed 12 years ago

#4050 closed defect (fixed)

Admin tab visibility does not respect authentication via group membership

Reported by: jeffstewart@… Owned by: Matthew Good
Priority: normal Milestone: 0.11
Component: admin/web Version: 0.10.2
Severity: normal Keywords: permission groups
Cc: Branch:
Release Notes:
API Changes:

Description

Adding the TRAC_ADMIN permission to a group of users created using the steps in http://trac.edgewall.org/wiki/TracPermissions#PermissionGroups does not cause the Admin tab to appear when a member of that group authenticates.

Attachments (1)

permissionoutput.txt (2.2 KB ) - added by swithin@… 12 years ago.
Output of "python trac-admin c:\svn\trac.db permission list > permissionoutput.txt"

Download all attachments as: .zip

Change History (10)

comment:1 by info@…, 12 years ago

Version: 0.100.10.2

same with my installation. some solutions?

comment:2 by Matthew Good, 12 years ago

Keywords: needinfo added; admin tab user group permission removed

First be sure you've enabled the plugin. You should also be sure to restart the Trac web server after installing a new plugin.

Are you saying it works when you add the TRAC_ADMIN permission to a specific user, but not with a group? If so can you provide the output of "trac-admin your-project permission list" and the names of users you've seen this with.

by swithin@…, 12 years ago

Attachment: permissionoutput.txt added

Output of "python trac-admin c:\svn\trac.db permission list > permissionoutput.txt"

comment:3 by anonymous, 12 years ago

I ran the permission dump that mgood requested against Trac 0.9.4 after I saw the same error myself (in Trac 0.9.4) and found this ticket. See attached file called permissionoutput.txt. Note in there there is a user called jfrenia. When he was only assigned to the Administrator group, he didn't see the Admin tab. But as soon as I added the TRAC_ADMIN permission, he could see it. I'm not sure if you will want to use this test output since it came from 0.9.4 rather than 10.2, but if the problem always existed (even in earlier versions of Trac), it should be valid output.

comment:4 by Noah Kantrowitz <coderanger@…>, 12 years ago

All group names should be lowercase. You have one called Administrator.

comment:5 by sid, 12 years ago

That has caught a lot of people, and is documented here: TracPermissions#PermissionGroups

comment:6 by Matthew Good, 12 years ago

Yes, at the moment you can't have any uppercase letters in a group name. I had the impression that they simply couldn't be all uppercase, but based on the code that's not true. Is there a reason to prevent mixed-case group names? This should be fairly easy to fix.

comment:7 by Christian Boos, 12 years ago

Keywords: permission groups added; needinfo removed
Milestone: 0.11

So what do we do about this ticket and the possibility to have mixed-case group names. As we're working on the permissions for 0.11, it's probably a good time to decide about this.

comment:8 by Matthew Good, 12 years ago

Owner: changed from Christopher Lenz to Matthew Good
Status: newassigned

Yeah, currently mixed case names are being considered as permissions rather than groups, so I think it makes sense to switch that around.

comment:9 by Matthew Good, 12 years ago

Resolution: fixed
Status: assignedclosed

Done in r4958.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted.
to The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.