Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#3969 closed defect (fixed)

TypeError: an integer is required

Reported by: goldent Owned by: Christian Boos
Priority: normal Milestone: 0.10.1
Component: version control/browser Version: devel
Severity: trivial Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /changeset/102, Trac issued an internal error.

System Information

Python 2.4.3 (#69, Mar 29 2006, 17:35:34) [MSC v.1310 32 bit (Intel)]
Subversion 1.4.0
SQLite 3.3.6
pysqlite 2.3.2

Python Traceback

Traceback (most recent call last):
  File "c:\python24\Lib\site-packages\trac\web\main.py", line 377, in dispatch_request
    dispatcher.dispatch(req)
  File "c:\python24\Lib\site-packages\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "c:\python24\Lib\site-packages\trac\versioncontrol\web_ui\changeset.py", line 249, in process_request
    self._render_html(req, repos, chgset, restricted, message, data)
  File "c:\python24\Lib\site-packages\trac\versioncontrol\web_ui\changeset.py", line 467, in _render_html
    diffs = _content_changes(old_node, new_node)
  File "c:\python24\Lib\site-packages\trac\versioncontrol\web_ui\changeset.py", line 435, in _content_changes
    ignore_space_changes=ignore_space)
  File "c:\python24\Lib\site-packages\trac\versioncontrol\diff.py", line 176, in diff_blocks
    line = line.expandtabs(tabwidth)
TypeError: an integer is required

Attachments (0)

Change History (6)

comment:1 by mail@…, 15 years ago

I'm using the current Subversion HEAD (r3996) and this error apparently happens on any attempt to access a /changeset URL

comment:2 by Christian Boos, 15 years ago

Milestone: 0.11
Severity: normalminor

Looks like you have neither of those options set in your TracIni:

[diff]
tab_width = ...

[mimeviewer]
tab_width = ...

but we should probably default to '8' in this case.

comment:3 by Christian Boos, 15 years ago

Resolution: fixed
Severity: minortrivial
Status: newclosed

Fixed by r3998.

in reply to:  3 ; comment:4 by anonymous, 15 years ago

Replying to cboos:

Fixed by r3998.

Thank you so much. I couldn't believe how fast that fix was. In fact my trac.ini had a tab_width = <blank> entry, which I've now set in any case.

in reply to:  4 comment:5 by Christian Boos, 15 years ago

Replying to anonymous:

… In fact my trac.ini had a tab_width = <blank> entry, which I've now set in any case.

was that a newly created env, or because you set it like that by mistake?

comment:6 by Christian Boos, 15 years ago

Milestone: 0.110.10.1

Ported to 0.10-stable in r4016.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.