Edgewall Software
Modify

Opened 15 years ago

Last modified 6 years ago

#3794 new defect

Invalid table(with indentation) layout in wiki.

Reported by: tdkim@… Owned by:
Priority: normal Milestone: topic-wikiengine
Component: wiki system Version: devel
Severity: minor Keywords: table lists
Cc: tdkim@…, andrex@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

The following wiki markup:

 * this is a table example.
   || This row has a '''wrong''' indentation. ||
   || This row has a correct indentation. ||
   || This row has a correct indentation. ||

 * this is a correct block example.
   {{{
#!c
int i = 0;
printf("%d", i);
   }}}

Renders as:

  • this is a table example.
This row has a wrong indentation.
This row has a correct indentation.
This row has a correct indentation.
  • this is a correct block example.
    int i = 0;
    printf("%d", i);
    

Attachments (0)

Change History (9)

comment:1 by Christian Boos, 15 years ago

Milestone: 0.10.1
Owner: changed from Jonas Borgström to Christian Boos
Severity: normalminor

Thanks for the report and the example, I'll try to make this work for the next bug fix release.

comment:2 by tdkim@…, 15 years ago

This is a more infomation.

|| This is no indentation. ||

{{{
This is no indentation.
}}}

 || This must have a 1 indentation. ||

 {{{
This must have a 1 indentation.
 }}}

   || This must have 2 indentations. ||

   {{{
This must have 2 indentations. ||
   }}}
This is no indentation.
This is no indentation.
This must have a 1 indentation.
This must have a 1 indentation.
This must have 2 indentations.
This must have 2 indentations. ||

Thanks for Trac…

comment:3 by Christian Boos, 15 years ago

Milestone: 0.10.50.11

I'll have a look if the new WikiEngine can handle this better…

comment:4 by Christian Boos, 14 years ago

Milestone: 0.110.12

WikiEngine refactoring and related fixes postponed.

comment:5 by Christian Boos, 12 years ago

Description: modified (diff)
Keywords: table lists added
Milestone: next-major-0.1X0.13

#6482 has been closed as duplicate of this ticket.

comment:6 by andrex@…, 11 years ago

Cc: andrex@… added

comment:7 by mark.sethi@…, 11 years ago

I've been beating my head against this one and found that the following works:

 * Some item

 ||indentation! ||my fancy||table||
 ||woot||

Which displays as:

  • Some item
indentation! my fancytable
woot

The extra newline seems to fix the problem, and you need as many spaces as you want indents, both of which are counter-intuitive. Of course this means if you're including a table in an ordered list, you will have to reset the counter with the following item.

comment:8 by Christian Boos, 11 years ago

Milestone: 0.130.14-wikiengine

comment:9 by Ryan J Ollos, 6 years ago

Owner: Christian Boos removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.