Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#3779 closed defect (fixed)

Reports takes minutes to complete

Reported by: omry at yadan dot net Owned by: Christian Boos
Priority: high Milestone: 0.10.1
Component: wiki system Version: 0.10b1
Severity: critical Keywords: slow
Cc: trac@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

My database contains about 35 tickets. recently reports started to work very slowly. when I open a report, apache cpu usage spikes to 100% for a few minutes (!) and then I get the results. I inserted the sql query directly into sqlite3, and it returned instantly


Note: this is a problem with the wiki engine, when rendering attachment:ticket35.txt
— cboos

Attachments (2)

trac.db.sqlite3.zip (201.0 KB ) - added by omry 16 years ago.
my database file. (sqlite 3)
ticket35.txt (756 bytes ) - added by anonymous 16 years ago.

Download all attachments as: .zip

Change History (26)

comment:1 by omry, 16 years ago

if you need my database or anything else to reproduce, just ask.

comment:2 by Christian Boos, 16 years ago

Can you first try if this is reproductible for you using tracd?

comment:3 by Matthew Good, 16 years ago

Keywords: needinfo added

comment:4 by omry, 16 years ago

it is.

comment:5 by omry, 16 years ago

I mean, it is reproduceable with tracd.

by omry, 16 years ago

Attachment: trac.db.sqlite3.zip added

my database file. (sqlite 3)

comment:6 by omry, 16 years ago

Keywords: needinfo removed
Milestone: 0.10.1

assigned to milestone 0.10.1

comment:7 by Emmanuel Blot, 16 years ago

Milestone: 0.10.1

Do not assign a milestone without providing a reason or a patch.

Please describe your environment (version of the OS, Python, Svn, Pysqlite, etc.)

comment:8 by omry, 16 years ago

Debian etch. Kernel 2.6.15. Python 2.4 SVN 1.3.2 pysqlite: 1.1.7-2 AND 2.3.2-1 (could this be the problem?)

comment:9 by anonymous, 16 years ago

and sqlite 3.3.7

comment:10 by trac@…, 16 years ago

registered email.

comment:11 by trac@…, 16 years ago

figured it out: ticket 35 in the attached database had a long message insife ![brackets]. when I deleted it from the database all went back to normal.

comment:12 by Christian Boos, 16 years ago

Owner: changed from daniel to Christian Boos

hm, that's not a good reason to take minutes… Can you please copy/paste that message in a block, here? (or attach it?)

comment:13 by trac@…, 16 years ago

Cc: trac@… added

I removed it from my database, but its in the attached file. ticket 35.

comment:14 by franck34, 16 years ago

After upgrade sqlite2 → sqlite3, got same problem. Very slow and httpd > 99% CPU (eaccelerator website …)

comment:15 by franck34, 16 years ago

sorry, i forgot some things: Fedora Core 3, Python 2.4 Trac 0.9.3

Before update sqlite, everything was ok.

comment:16 by anonymous, 16 years ago

franck34, as an emergency care, find the bad ticket and remove it from the database. you can do it by viewing all the tickets on at a time till you find the slow one. there was no obvious way to remove the ticket, but I found something after some searching.

comment:17 by franck34, 16 years ago

Keywords: slow added

Very good !

I found a ticket with a description > 300 000 chars.

I've change the description of this ticket and i put 99% of the description in an attachement instead of directly in the description.

Now everything is ok, problem solved for me.

comment:18 by franck34, 16 years ago

As suggested by matt_good on irc, request feature as been written in ticket #3944

comment:19 by anonymous, 16 years ago

My problem is not due to a huge ticket size. I extracted the ticket content from the database and I am attacing.

by anonymous, 16 years ago

Attachment: ticket35.txt added

comment:20 by Christian Boos, 16 years ago

Component: report systemwiki
Description: modified (diff)
Milestone: 0.10.1

Right, problem reproduced. Thanks for having extracted the ticket35.txt ;)

comment:21 by Christian Boos, 16 years ago

Ok, the problem comes from the definition list regexp. The stuff I added for being a bit more robust in the presence of `...` quotes have some performance issues (ref #2082, #2083).

comment:22 by Christian Boos, 16 years ago

Resolution: fixed
Status: newclosed

Above issue fixed by r3949:3950.

comment:23 by Christian Boos, 16 years ago

Summary: Reports takes minutes to compleetReports takes minutes to complete

comment:24 by anonymous, 16 years ago

great, thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.