Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#3387 closed defect (fixed)

Permission error raised viewing new changesets

Reported by: Markus Tacker <m@…> Owned by: Matthew Good
Priority: high Milestone: 0.10.1
Component: version control/changeset view Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

In r3521

Trac [/var/trac/xxx]> permission list

User                           Action
---------------------------------------------
customerUserA                  customer
customer                       BROWSER_VIEW
customer                       CHANGESET_VIEW
customer                       FILE_VIEW
customer                       LOG_VIEW
customer                       REPORT_VIEW
customer                       TICKET_APPEND
customer                       TICKET_CREATE
customer                       TICKET_VIEW
customer                       WIKI_CREATE
customer                       WIKI_MODIFY
customer                       WIKI_VIEW

if the logged in customerUserA views a changeset he gets a Insufficient permissions to access changeset.

Attachments (3)

2006-08-07_094705.png (8.8 KB ) - added by Markus Tacker <m@…> 13 years ago.
2006-08-07_094718.png (9.7 KB ) - added by Markus Tacker <m@…> 13 years ago.
2006-08-07_094744.png (5.8 KB ) - added by Markus Tacker <m@…> 13 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by Markus Tacker <m@…>, 13 years ago

I cannot reproduce this with a fresh install. I set up a new install an gave anonymous only CHANGESET_VIEW, which works. It also works with an authenticated user there.

I tried removing all permissions and readding them to no avail.

Is there a way to debug this?

comment:2 by Markus Tacker <m@…>, 13 years ago

And, of course it used to work for about six months.

by Markus Tacker <m@…>, 13 years ago

Attachment: 2006-08-07_094705.png added

by Markus Tacker <m@…>, 13 years ago

Attachment: 2006-08-07_094718.png added

by Markus Tacker <m@…>, 13 years ago

Attachment: 2006-08-07_094744.png added

comment:3 by Markus Tacker <m@…>, 13 years ago

Today it happened again. This time I am logged in as TRC_ADMIN.

I go to a wiki page listing our releases. Note that the link to r1057 is greyed.

I clicked on resulting in "Forbidden".

Now I went to the timeline. From there I could access the revision.

I have the feeling that this happens only with the latest revision and only the first time it is accessed.

comment:4 by soporte@…, 13 years ago

I ended in this issue too.

happends only one time, even when Im log as a TRAC_ADMIN, then I visit the wiki or some other page, return to the changeset, and the error message is gone.

Im running: trac 0.9.6 Python 2.4.3 mod_python-3.2.8 with apache 2.2.2 in FC5.

comment:5 by Matthew Good, 13 years ago

Milestone: 0.10.1
Owner: changed from Jonas Borgström to Matthew Good
Summary: CHANGESET_VIEW permission brokenPermission error raised viewing new changesets

The error actually has nothing to do with the users' permissions. The error message is obviously confusing, but the real issue is that Trac is not resyncing with the repository before trying to display the changeset, so it's not available in the cache.

comment:6 by Matthew Good, 13 years ago

Status: newassigned

comment:7 by Markus Tacker <m@…>, 13 years ago

If I visit the "Browse Source" page and reload the Timeline page, the new rev is / accessable.

comment:8 by Matthew Good, 13 years ago

Priority: normalhigh

comment:9 by Matthew Good, 13 years ago

Resolution: fixed
Status: assignedclosed

Fixed in r3971 and r3972.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.