Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#3296 closed defect (duplicate)

No Support for --home=~ Python Installations

Reported by: trac@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.5
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Set severity as major as this pretty much completely prevents the use of trac on a system in which —home=~ is used. I initially patched the setup.py to change the siteconfig method in my_install (attached), however there are more problems, the search path gets messed up as well causing the scan for plugins to attempt to create (via setuptools) /Library/Webserver/.python-eggs

Attachments (1)

trac-home-patch1.patch (1.3 KB ) - added by trac@… 16 years ago.
patch for setup.py

Download all attachments as: .zip

Change History (4)

by trac@…, 16 years ago

Attachment: trac-home-patch1.patch added

patch for setup.py

comment:1 by Emmanuel Blot, 16 years ago

Severity: majornormal

I may not understand the bug report, but ~home should be used with care: ~home should be replaced with $HOME, as the shell (which translates the ~home alias into the actual directory) may not work when ~ is prefixed with other characters, such as —install-dir= for example.

Can you give more details about the actual issue ?

comment:2 by trac@…, 16 years ago

Digging into this a little more, the second problem seems to be somewhat related to the setuptools side of things, due to being in a CGI script setuptools tries to use the cwd as the place to unpack the eggs but since it is not writable by the script (the web server runs it as nobody) it can't make the directory… and that is covered in the PYTHON_EGG_CACHE bit in the CGI install… so just the first problem please ;)

Re: your response

there is no "~home" that is a shell magic folders thing, i am talking about using a —home=~ set up in python: http://python.org/doc/current/inst/alt-install-windows.html#SECTION000310000000000000000

comment:3 by Christopher Lenz, 16 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #963.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.