Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#3276 closed enhancement (duplicate)

RSS author default domain

Reported by: andybe@… Owned by: Christian Boos
Priority: normal Milestone:
Component: general Version: 0.9.5
Severity: normal Keywords: rss
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

RSS author fields currently do not work unless a user sets their email address (due to an RSS requirement for email addresses?)

It would be extremely useful to have a trac.ini setting, in much the same vein as smtp_default_domain in version 0.10dev that would add a default domain to usernames, and use that for the author field (Reference #2245 for an alternative).

Attachments (0)

Change History (5)

comment:1 by Emmanuel Blot, 15 years ago

… or may be make the smtp_default_domain not restricted to notification, but generalize it to any email address in Trac space ?

Would there be some use cases where a (default) domain would be different for ticket notification and RSS news ?

comment:2 by Christian Boos, 15 years ago

Keywords: rss added
Milestone: 0.10
Owner: changed from Jonas Borgström to Christian Boos

I'm not sure, but I think that the smtp_default_domain is never exported publicly. If we use it in a RSS feed, it suddenly will, so I imagine that this might not be desired sometimes.

Anyway, I think it's better to use a more explicit option name, like [notification] rss_default_domain. I think it's OK to reuse the notification section here, as RSS is also a kind of notification. Most of the mail notification options are prefixed with smtp_, so there won't be a confusion.

comment:3 by Christian Boos, 15 years ago

Milestone: 0.100.11

As there's no big enthusiasm for the idea, let's post-pone this to milestone:0.11

comment:4 by Emmanuel Blot, 15 years ago

I think it is fair to postpone it to 0.11, as adding default values may be a new source of new bugs.

I'm ok with the rss_default_domain option, although I do not think at the moment of a hidden RSS domain with a public SMTP domain. Is there a use case for this?

comment:5 by Christian Boos, 15 years ago

Milestone: 0.11
Resolution: duplicate
Status: newclosed

Btw, this ticket is a duplicate of #2639.

Here's what I propose: use the smtp_default_domain for that, until someone shows a use-case where it would be better to have a different setting…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.