Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#3126 closed enhancement (worksforme)

The ticket viewer template does resize text regions to fit the client.

Reported by: anonymous Owned by: Jonas Borgström
Priority: low Milestone:
Component: ticket system Version: 0.9.5
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When viewing a ticket on a widescreen monitor, the ticket only takes up half my screen space.

Attachments (1)

3126.gif (35.5 KB ) - added by anonymous 16 years ago.
Screenshot of client viewing a ticket

Download all attachments as: .zip

Change History (8)

comment:1 by anonymous, 16 years ago

Summary: The ticket viewer template does resize the text regions to fit the client.Optional pagenation of reports.

Viewing reports with a large number of tickets can result in very long waits.

comment:2 by anonymous, 16 years ago

Summary: Optional pagenation of reports.The ticket viewer template does resize the text regions to fit the client. to Optional pagenation of reports.

comment:3 by anonymous, 16 years ago

Summary: The ticket viewer template does resize the text regions to fit the client. to Optional pagenation of reports.The ticket viewer template does resize text regions to fit the client.

comment:4 by Emmanuel Blot, 16 years ago

Component: generalticket system
Priority: normallow
Severity: normalminor

comment:5 by Emmanuel Blot, 16 years ago

I'm not sure about which pages you've reported this issue: is it about the report pages or the ticket pages?

  • the ticket page does not resize up to a maximum width of a wide screen - I'm not sure it is feasible without breaking the whole ticket page presentation with more 'regular' widths.
  • however, the report page does resize well up to the maximum width.

by anonymous, 16 years ago

Attachment: 3126.gif added

Screenshot of client viewing a ticket

comment:6 by Emmanuel Blot, 16 years ago

Ok, so according to the snapshot, this request for enhancement is about the ticket view, not the report view.

Time issue with the report view is addressed in a dedicated ticket: #3135. ("Viewing reports with a large number of tickets can result in very long waits." is no longer addressed by this ticket)

comment:7 by Christian Boos, 16 years ago

Resolution: worksforme
Status: newclosed

It's by design. The Trac Committee of Esthetics thinks that filling the whole available horizontal space would be less than optimal (esthetically speaking, that is).

Extract of the committee's minutes:

<cboos>	there's a ticket about the ticket module taking a fixed width, and sure that's easy to fix, as there's a width set to 700px. But is it a good thing to have this by default? Why not let the size unspecified in the default setup?
<alect>	looks ugly as hell
<cmlenz>cboos: that would make the tickets look quite awful on large screens
* alect	<- 1920x1200 == ugly as hell

If you disagree, simply add the following custom rule in your site_css.cs file: #content.ticket { width: auto; }

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.