Edgewall Software
Modify

Opened 12 years ago

Closed 2 years ago

#2968 closed enhancement (duplicate)

need a "contains" option for Owner if restrict_owner is true

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.9.4
Severity: normal Keywords: restrict_owner
Cc: tim@…
Release Notes:
API Changes:

Description (last modified by Ryan J Ollos)

#1439 ([1664]) tied up the restrict_owner to control not only the newticket page but also the query page.

However in light of requests to edit or clean-up the userlist (#2351, #1347) - it should be recognised that dropdown for owners of "new tickets" may not be the same as the owners you want to search for.

so we need the "contains, startswith, endswith" options for owner even if the restrict_owner is true.

This does stop those of us using the "query" system from effectively managing our reporters.

Attachments (0)

Change History (8)

comment:1 Changed 12 years ago by anonymous

Cc: tim@… added

comment:2 Changed 11 years ago by sid

Type: defectenhancement
Last edited 2 years ago by Ryan J Ollos (previous) (diff)

comment:3 Changed 11 years ago by Christian Boos

Keywords: restrict_owner added
Milestone: 0.12

comment:4 Changed 10 years ago by Eli Carter

The list of owners you want to search for would be the union of the owners available in the new ticket list and the all the owners in the database. I expect that the latter would be an expensive operation.

comment:5 Changed 7 years ago by Christian Boos

Milestone: next-major-0.1Xunscheduled

comment:6 Changed 3 years ago by Ryan J Ollos

Owner: Jonas Borgström deleted

comment:7 Changed 2 years ago by Ryan J Ollos

Description: modified (diff)

comment:8 Changed 2 years ago by Ryan J Ollos

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

Adding autocomplete in #7628 will allow us to keep a text field when restrict_owner is true. Closing as a duplicate of #7628.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.