Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#2963 closed defect (fixed)

UnicodeEncodeError

Reported by: afort@… Owned by: Christian Boos
Priority: high Milestone: 0.10
Component: version control/changeset view Version: devel
Severity: normal Keywords: unicode UnicodeEncodeError
Cc: m@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm using r3085.

In Changeset view. It seems non ascii log message causes it.

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 299, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 175, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/changeset.py", line 200, in process_request
    req.check_modified(chgset.date, [
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 268, in check_modified
    m.update(str(elt))
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-6: ordinal not in range(128)

Attachments (0)

Change History (5)

comment:1 by anonymous, 16 years ago

Milestone: 0.10
Resolution: duplicate
Status: newclosed

Duplicate of #2905.

comment:2 by Christian Boos, 16 years ago

Milestone: 0.10
Resolution: duplicate
Status: closedreopened

Well, in the same category as #2905 probably, but not really a duplicate. Here, it's the m.update(str(elt)) in check_modified in trunk/trac/web/api.py that we have to fix…

comment:3 by Markus Tacker <m@…>, 16 years ago

Cc: m@… added

comment:4 by Christian Boos, 16 years ago

Owner: changed from Jonas Borgström to Christian Boos
Priority: normalhigh
Status: reopenednew

I think I'm about to fix most of the unicode issues related to SVN… Stay tuned.

comment:5 by Christian Boos, 16 years ago

Resolution: fixed
Status: newclosed

This particular issue should be fixed by r3091.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.