Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#2921 closed defect (invalid)

Failure sending notification

Reported by: xavi@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

I'm getting the following error when adding a new ticket or changing an existing one. I'm running 0.9.4 an my trac.ini [notification] section looks like:

[notification]
always_notify_owner = true
smtp_always_cc = xbeumala@communi.tv
smtp_password = XXXXXXXX
smtp_enabled = true
smtp_replyto = xbeumala@comuni.tv
smtp_port = 25
always_notify_reporter = true
always_notify_owner = true
smtp_server = mail.communi.tv
smtp_from = dev@communi.tv
smtp_user = dev@communi.tv

Here's the error.

21:59:03 Trac[web_ui] ERROR: Failure sending notification on change to ticket #6: (-2, 'Name or service not known')
Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/ticket/web_ui.py", line 352, in _do_save
    tn.notify(ticket, newticket=False, modtime=now)
  File "/usr/lib/python2.3/site-packages/trac/Notify.py", line 211, in notify
    NotifyEmail.notify(self, ticket.id, subject)
  File "/usr/lib/python2.3/site-packages/trac/Notify.py", line 108, in notify
    Notify.notify(self, resid)
  File "/usr/lib/python2.3/site-packages/trac/Notify.py", line 45, in notify
    self.begin_send()
  File "/usr/lib/python2.3/site-packages/trac/Notify.py", line 116, in begin_send
    self.server = smtplib.SMTP(self.smtp_server, self.smtp_port)
  File "/usr/lib/python2.3/smtplib.py", line 254, in __init__
    addr = socket.gethostbyname(socket.gethostname())
gaierror: (-2, 'Name or service not known')

I've been looking into another similar tickets, but doesn't seems to work for me.

Thanks a lot for your great work!

X.

Attachments (0)

Change History (6)

comment:1 by Emmanuel Blot, 16 years ago

Description: modified (diff)

Which OS are you using ?

Can you try to run a SMTP test from a simple Python script, such as:

import smtplib
s = smtplib.SMTP('mail.communi.tv', 25)
s.login('dev@communi.tv', 'ctvdev05')
s.sendmail('dev@communi.tv', ['dev@communi.tv'], "TEST")
s.close()

Do not forgot to run your test with the same user as your web server. Some Linux systems do not accept SMTP outgoing connection from the web 'user', for example…

Anyway, there's something wrong with this setup:

telnet mail.communi.tv 25
Trying 217.116.16.4...
Connected to mail.communi.tv.
Escape character is '^]'.
220 bandalatina.com ESMTP
EHLO free.fr
250-bandalatina.com
250-PIPELINING
250-8BITMIME
250 SIZE 15000000

Your email server does not report support for authentication (AUTH), whereas you are explicitly authenticating on the server (smtp_user, smtp_password). It should report something as:

250-AUTH PLAIN

for example.

comment:2 by anonymous, 16 years ago

Resolution: fixed
Status: newclosed

Well the script didn't work for me and I was receiving againa getHostName() error. I've been digging and have found the error was due to a bad configuration of resolf.conf

Read more http://www.python.org/cgi-bin/faqw-mm.py?req=edit&file=faq06.014.htp

P.D: When I posted the bug I forgot to change the data of the smpt server. Could the admins please remove at least the password? Thanks so much

comment:3 by Christian Boos, 16 years ago

Description: modified (diff)

(removed password)

comment:4 by Christian Boos, 16 years ago

(well, kind of, because the Trac Ticket mailing list is a public one, so the password is still visible in the archives, in the mails corresponding to the ticket creation and to the above change, so you'd better change your password anyway)

comment:5 by anonymous, 16 years ago

Resolution: fixed
Status: closedreopened

comment:6 by Emmanuel Blot, 16 years ago

Resolution: invalid
Severity: majornormal
Status: reopenedclosed

not a bug

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.