Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#2920 closed defect (worksforme)

error while code browsing

Reported by: anonymous Owned by: Christian Boos
Priority: normal Milestone:
Component: version control Version: 0.9.4
Severity: normal Keywords: svn needinfo
Cc: sree@… Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

Oops...
Trac detected an internal error:

("Can't set position pointer in file '/projects/snapcore/db/revs/1': Invalid argument", 22)

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide
Python traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 93, in process_request
    node = get_existing_node(self.env, repos, path, rev)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/util.py", line 87, in get_existing_node
    return repos.get_node(path, rev)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 103, in get_node
    return self.repos.get_node(path, rev)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 261, in get_node
    self.pool)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 363, in __init__
    self.root = fs.revision_root(fs_ptr, rev, self.pool())
SubversionException: ("Can't set position pointer in file '/projects/snapcore/db/revs/1': Invalid argument", 22)

I have refered and did all the things mentioned in ticket:2770. Also verified the repository using the script ticket:2620

its clearly failing at self.pool() in svn_fs.py

any help is appreciated.

  • sree

Attachments (0)

Change History (9)

comment:1 by Christian Boos, 14 years ago

Component: browserversion control
Description: modified (diff)
Keywords: svn130 added
Owner: changed from Jonas Borgström to Christian Boos

Also verified the repository using the script ticket:2620

its clearly failing at self.pool() in svn_fs.py

So the script fails when you try to access rev 1? Can you also provide the stack trace for that error?

comment:2 by Christian Boos, 14 years ago

I also found a thread on the Subversion list, which suggests a possible cause for your problem: SubversionDev:72146.

Please don't forget to provide some feedback here in the case you were able to troubleshoot the issue.

comment:3 by anonymous, 14 years ago

Resolution: fixed
Status: newclosed

comment:4 by Christian Boos, 13 years ago

Keywords: svn needinfo added; svn130 removed
Priority: highnormal
Resolution: fixed
Status: closedreopened

#3586 marked as duplicate.

I'm reopening this, as we don't have yet a satisfactory confirmation that this issue is due to an apr_off_t incompatibility, as suggested in the mailing list thread mentionned above.

Please do report here if you were able to solve the issue by following those advices.

comment:5 by kentaro, 13 years ago

My Subversion and Apache2 had used the different version of apr library. So I recomplied subversion with the save apr, apr-util which Apache2 used, and solved this issue.

comment:6 by Christian Boos, 13 years ago

Resolution: worksforme
Status: reopenedclosed

Thanks for the feedback. I'll add this information in our TracSubversion page.

comment:7 by ThurnerRupert, 12 years ago

#5832, #5709 marked as duplicate …

comment:8 by kronos, 12 years ago

I have same problem. The solution is install latest version of subversion.I have install svn-1.4.4 and now its ok.

comment:9 by skiidoo, 12 years ago

Using Gentoo, I upgraded Subversion to the latest version available as of time (dev-util/subversion-1.4.4-r4) but that didn't solved the issue.

I had a look at the TracSubversion Troubleshooting section and ran ldd against the binaries, but they all showed the same apr,apr-util version. Finally I recompiled apr apr-util & apache too, and this solved the problem.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.