Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2832 closed enhancement (duplicate)

Tickets / Date Set

Reported by: o.jauerneck@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.9.3
Severity: normal Keywords: ticket date delete
Cc: Branch:
Release Notes:
API Changes:

Description

Hello,

I'd like to propose a feature for the ''ticket system'' of Trac. It'd be nice if someone could ''set a date'' when a Ticket has to be solved the lastest and if an user could not only see the label ''created x days ago'' but also the ''date itself''. A possibility of ''deleting'' instead of just ''closing'' tickets would be nice, too.

Best regards, Oliver Jauerneck, Germany

Attachments (0)

Change History (5)

comment:1 by jornh, 14 years ago

Resolution: worksforme
Status: newclosed

I think that's 3 features you propose, and most of it is already there :-)

  • You can use a custom field - see TracTicketsCustomFields - for the "due date"
  • The "create date" is already visible if you hover the mouse over the "x days" ago text
  • Deleting tickets is already implemented as an admin option in the trunk version and will be available in 0.10

comment:2 by anonymous, 14 years ago

Milestone: 1.0

comment:3 by anonymous, 14 years ago

Resolution: worksforme
Status: closedreopened

Many thanks to jornh's reponse for providing us with a tip on customizing "due date" field. However, I checked the field type, there is no DATE type. It would be helpful if there is a date type, otherwise people are going to enter the date text differently depending on the country of origin. For example, the date format in US is MM-DD-YYYY whereas in Australia it's DD-MM-YYYY. It's would be nice to have a date type, so we can generate a ticket report based on "Due Date" column.

comment:4 by Matthew Good, 14 years ago

Resolution: duplicate
Status: reopenedclosed

Then this is a duplicate of #1942.

comment:5 by anonymous, 14 years ago

test

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.