Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#2742 closed defect (duplicate)

trac-admin /srv/trac/whatever initenv fails

Reported by: bero@… Owned by: daniel
Priority: normal Milestone:
Component: admin/console Version: 0.9.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

# trac-admin /srv/trac/test initenv Creating a new Trac environment at /srv/trac/test

Trac will first ask a few questions about your environment in order to initalize and prepare the project database.

Please enter the name of your project. This name will be used in page titles and descriptions.

Project Name [My Project]> Test - testing trac

Please specify the connection string for the database to use. By default, a local SQLite database is created in the environment directory. It is also possible to use an already existing PostgreSQL database (check the Trac documentation for the exact connection string syntax).

Database connection string db/trac.db>

Please specify the absolute path to the project Subversion repository. Repository must be local, and trac-admin requires read+write permission to initialize the Trac database.

Path to repository var/svn/test> /srv/svn/test

Please enter location of Trac page templates. Default is the location of the site-wide templates installed with Trac.

Templates directory usr/share/trac/templates>

Creating and Initializing Project Failed to create environment. You can only execute one statement at a time. Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/trac/scripts/admin.py", line 139, in env_create

self.env = Environment(self.envname, create=True, db_str=db_str)

File "/usr/lib/python2.4/site-packages/trac/env.py", line 79, in init

self.create(db_str)

File "/usr/lib/python2.4/site-packages/trac/env.py", line 197, in create

db.init_db(self.path, db_str)

File "/usr/lib/python2.4/site-packages/trac/db.py", line 442, in init_db

cls.init_db(args)

File "/usr/lib/python2.4/site-packages/trac/db.py", line 326, in init_db

cursor.execute(stmt)

Warning: You can only execute one statement at a time. Failed to initialize environment. 1 Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/trac/scripts/admin.py", line 594, in do_initenv

self.env_create(db_str)

File "/usr/lib/python2.4/site-packages/trac/scripts/admin.py", line 144, in env_create

sys.exit(1)

SystemExit: 1

trac 0.9.3, used with Python 2.4.2, sqlite 3.3.3, pysqlite 2.0.5, subversion 1.3.0

Attachments (0)

Change History (3)

comment:1 by bero@…, 16 years ago

Might be related to #1822, but this is a fresh install, and I'm using trac 0.9.3 (http://projects.edgewall.com/trac/wiki/TracInstall says it's ok to use pysqlite 2.x with 0.9.x)

comment:2 by Christian Boos, 16 years ago

Resolution: duplicate
Status: newclosed

sqlite 3.3.3, pysqlite 2.0.5: they are not compatible.

Please check the PySqlite page.

Duplicate of #2719.

comment:3 by santosj, 16 years ago

As much as Trac is awesome trac-admin is bug riddled. This could one of two things:

Either I as the user sucks Or trac-admin sucks

I would assume that since people have been able to get trac to install correctly without error, that the former is true. With all of the bugs related to the matter of trac-admin, I would also have to say that the latter is true also. After spending many hours and days, I'm beginning to suspect that waiting for the next version would be a relatively good idea.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.