Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#2660 closed defect (duplicate)

Browse Source throws exception after deleting and renaming a directory in Subversion

Reported by: humandoing@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/browser Version: 0.9.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I have a Java source tree with a package structure like this (also seen below in the traceback):

/src/net/humandoing/evolution/domain/interfaces…

What I did was in my subversion client I renamed the "evolution" directory to something else. In effect, it was removing it from the repository, and scheduling the directory with the new name for addition.

After I made all my subversion commits, I went to Trac to browse the source, and it had stopped working (prior to this commit it was working fine).

I tried restarting the web server and fcgi processes that are running my Trac instance, but it was to no avail.

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/trac/web/fcgi_frontend.py", line 40, in _handler

dispatch_request(req.path_info, req, env)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 115, in process_request

self._render_directory(req, repos, node, rev)

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 147, in _render_directory

changes = get_changes(self.env, repos, [irev for i in info])

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/util.py", line 31, in get_changes

changeset = repos.get_changeset(rev)

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 42, in get_changeset

self.sync()

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 83, in sync

for path,kind,action,base_path,base_rev in changeset.get_changes():

File "/usr/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 488, in get_changes

change.base_path, pool())

SubversionException: ("File not found: revision 22, path '/src/net/humandoing/evolution/domain/interfaces/Process.java'", 160013)

Attachments (0)

Change History (2)

comment:1 by anonymous, 16 years ago

Ack. I think this is the same as 2416, which has been closed. If so, humble apologies.

comment:2 by Christian Boos, 16 years ago

Resolution: duplicate
Status: newclosed

Actually, that's a duplicate of #2440, I think. Please upgrade to 0.9.3.

(r2461 was a fix for a Windows specific problem)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.