Edgewall Software
Modify

Opened 13 years ago

Closed 2 years ago

#2642 closed enhancement (duplicate)

Ticket view should optionally reflect smtp_always_cc value for better transparency

Reported by: seemant@… Owned by:
Priority: low Milestone:
Component: notification Version: 0.9.3
Severity: minor Keywords: notification
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Summary says it all, come to think of it, but I'll paste the irc snippet that's relevant to this:

15:45 < cmlenz> seemant: I still don't understand why the current
                smtp_always_cc isn't sufficient for you
15:45 < seemant> cmlenz: I'm hoping it is, it's just nice to be able to see
                 that qa@ is actually cc'd on the ticket
15:46 < seemant> ie, the current method is non-transparent
15:46 -!- coderanger_work [n=coderang@vpnwl-228-2.net.rpi.edu] has joined #trac
15:47 -!- tag [n=chatzill@c-67-183-222-93.hsd1.wa.comcast.net] has joined #trac
15:47 < cmlenz> so simply adding the smtp_always_cc value to the *display* of
                the cc list (in the yellow ticket area) address that, right?
15:47 < seemant> yes!

Attachments (0)

Change History (11)

comment:1 by anonymous, 13 years ago

15:45 < cmlenz> seemant: I still don't understand why the current smtp_always_cc isn't sufficient for you
15:45 < seemant> cmlenz: I'm hoping it is, it's just nice to be able to see that qa@ is actually cc'd on the ticket
15:46 < seemant> ie, the current method is non-transparent
15:47 < cmlenz> so simply adding the smtp_always_cc value to the *display* of the cc list (in the yellow ticket area) address that, right?
15:47 < seemant> yes!

comment:2 by anonymous, 13 years ago

Component: generalticket system

comment:3 by Emmanuel Blot, 13 years ago

Description: modified (diff)

(adding verbatim tags to the description)

comment:4 by Emmanuel Blot, 13 years ago

Type: defectenhancement

I don't think adding this info into the CC: field is a good idea:

  1. the values from the smtp_always_cc are read-only, but there's no current solution to reflect this special status. This would mean special filter/extraction from the CC field when CC field is updated. → a text info (r/o) could be placed next to the CC field can fit.
  2. this feature should be optional, as some admin may not want internal addresses to appear on the web pages

comment:5 by Christopher Lenz, 13 years ago

About 1: I was suggesting only adding the address to the ticket view (the yellow area), not to the form control.

comment:6 by Emmanuel Blot, 13 years ago

My mistake, I've read the bug description too quickly ;-)

comment:7 by Christian Boos, 12 years ago

Component: ticket systemnotification
Milestone: 0.12
Owner: changed from Jonas Borgström to Emmanuel Blot
Priority: normallow
Severity: normalminor

If implemented, should probably be optional: not all smtp_always_cc value are as informative as the one given in the example.

comment:8 by Remy Blank, 9 years ago

Milestone: next-major-0.1Xunscheduled

comment:9 by hasienda <hoff.st@…>, 8 years ago

Summary: it would be nice if the ticket view would reflect the smtp_always_cc field just so that things are more transparentTicket view should optionally reflect smtp_always_cc value for better transparency

Shorten summary a bit to help with display readability and display in TicketQuery result lists.

comment:10 by Ryan J Ollos, 4 years ago

Owner: Emmanuel Blot removed

comment:11 by Peter Suter, 2 years ago

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

Duplicate of #8094? From comment:11:ticket:8094:

We could also show the smtp_always_cc address there if set

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.