Edgewall Software
Modify

Opened 17 years ago

Closed 16 years ago

#2582 closed defect (duplicate)

Duplication of ticket notification caused by unassigned value

Reported by: sarahg@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

In certain situations we've been getting duplicate emails. I think I finally narrowed it down:

"row" is not defined in the code here, its still got a carry-on value from a previous definition:

        # Harvest email addresses from the author field of ticket_change(s)
        if notify_reporter:
            cursor.execute("SELECT DISTINCT author,ticket FROM ticket_change "
                           "WHERE ticket=%s", (tktid,))
            for author,ticket in cursor:
                recipients.append(row[0])

Attachments (0)

Change History (3)

comment:1 by anonymous, 17 years ago

Summary: Ticket duplication caused by unassigned valueDuplication of ticket notification caused by unassigned value

comment:2 by sarahg@…, 17 years ago

This bug is at line 289 in Notify.py revision 2721. I thought I should specify since there's similar chunks of code nearby.

comment:3 by Matthew Good, 16 years ago

Resolution: duplicate
Status: newclosed

This is the same issue as #2408 which has been fixed.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.