Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#2515 closed defect (worksforme)

trac-admin should return nonzero if the command fails

Reported by: charles@… Owned by: daniel
Priority: normal Milestone:
Component: admin/console Version: 0.9.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

It would be helpful for trac-admin to return a nonzero value if the command fails (as in when invoked from the command line, not interactively). This would make it easier to write scripts that can determine right then and there whether the command succeeded.

Maybe I'm just slow, but my backup scripts are parsing the output, which incidentally changed for the hotcopy command since 0.8, leading to a little frustration on my part. This kind of thing could be avoided if I could glean some meaning from the return value of trac-admin.

I was going to add this as a comment to #2162 since they are outwardly similar, but I imagine it's an entirely different issue internally, hence a new ticket.

Attachments (1)

푸른 언덕.jpg (27.9 KB ) - added by anonymous 17 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 by Emmanuel Blot, 17 years ago

This seems to be a dup of #1960 for 0.9.2 (regression ?)

comment:2 by Matthew Good, 17 years ago

Resolution: worksforme
Status: newclosed

trac-admin does return non-zero values when it's exiting with an error. If there's a specific error that you're encountering that did not return a non-zero value please reopen this ticket with more information so that we can identify it.

by anonymous, 17 years ago

Attachment: 푸른 언덕.jpg added

comment:3 by charles@…, 17 years ago

You're right, it was fixed. I hadn't tested adequately since I upgraded from 0.8. My b.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.