Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#2514 closed enhancement (wontfix)

authz path regex support

Reported by: Bryan Drewery <bryan@…> Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I've suggested this on the SVN mailing list, if they like it, is there any chance trac would be willing to implement it?

Or possibly, add it anyway?

My problem is, svn's solution is to use <Location> directives to match paths with regex and to use a different authz file per path, so basically, I can do /

  • = r

.*/src/ ← done through apache

  • =

The problem is, trac has no way of recognizing this and only sees the * = r, and I'd rather avoid ~300 lines in my authz file to work around this for all of my branches/tags.

Attachments (0)

Change History (1)

comment:1 by Matthew Good, 16 years ago

Resolution: wontfix
Status: newclosed

SVN is currently the reference for the authz format, so there's no point in implementing syntaxes it doesn't support. If they choose to support more powerful path matching they may choose to use globs instead of regexes, which would leave Trac incompatible with the standard. If/when SVN implements this feature please reopen this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.