Edgewall Software
Modify

Opened 16 years ago

Closed 12 years ago

#2501 closed enhancement (duplicate)

wiki editing area should allow a lot more depth

Reported by: Chris Ryland <cpr@…> Owned by: Jonas Borgström
Priority: low Milestone:
Component: wiki system Version: 0.9.2
Severity: minor Keywords: patch
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Limiting the wiki editing area to 40 lines is pretty minimal.

How about a max of 80 or 100?

(Using Trac on a 30" monitor means I'm wasting a lot of available screen space.)

Attachments (0)

Change History (6)

comment:1 by sid, 16 years ago

For 0.10, this patch should do the trick:

  • templates/wiki.cs

     
    268268      <label for="editrows">Adjust edit area height:</label>
    269269      <select size="1" name="editrows" id="editrows" tabindex="43"
    270270        onchange="resizeTextArea('text', this.options[selectedIndex].value)"><?cs
    271        loop:rows = 8, 42, 4 ?>
     271       loop:rows = 10, 80, 10 ?>
    272272        <option value="<?cs var:rows ?>"<?cs
    273273          if:rows == wiki.edit_rows ?> selected="selected"<?cs /if ?>><?cs
    274274          var:rows ?></option><?cs

comment:2 by sid, 16 years ago

And for 0.11, this patch should do the equivalent:

  • wiki_edit.html

     
    6767          <div id="rows">
    6868            <label for="editrows">Adjust edit area height:</label>
    6969            <select size="1" name="editrows" id="editrows" tabindex="43">
    70               <option py:for="rows in range(8, 42, 4)" value="$rows"
     70              <option py:for="rows in range(10, 80, 10)" value="$rows"
    7171                      selected="${str(rows) == edit_rows or None}">
    7272                $rows
    7373              </option>

comment:3 by Christian Boos, 16 years ago

No, what would be really cool for wide screen would be side-by-side editing ;)

(see #2596, marked as duplicate of this one)

comment:4 by sid, 16 years ago

Keywords: patch added

Hmm, that does look very cool. Time to purchase a larger screen.

comment:5 by Christian Boos, 15 years ago

Milestone: 2.0

Hm, I should really do this wide-screen support one day, with synchronized scrolling of textarea and preview ;-)

in reply to:  5 comment:6 by Christian Boos, 12 years ago

Milestone: 2.0
Resolution: duplicate
Status: newclosed

Replying to cboos:

Hm, I should really do this wide-screen support one day, with synchronized scrolling of textarea and preview ;-)

Done so in #8721 :-)

Besides, the "wiki editing area should allow a lot more depth" topic has been addressed with the resizable textareas (#8216).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.