Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2352 closed defect (fixed)

Problem with umlaut in Subversion commit message

Reported by: horst.triebenbacher@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.9
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I have commited a change to the subversion repository. The message contains an umlaut ä and added a note to an existing ticket - using the ref directive.

Now I'm not able to view the ticket - see Traceback below:

Traceback (most recent call last):
  File "C:\Server\Python23\Lib\site-packages\trac\web\modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "C:\Server\Python23\Lib\site-packages\trac\web\main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Server\Python23\Lib\site-packages\trac\web\main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Server\Python23\Lib\site-packages\trac\ticket\web_ui.py", line 214, in process_request
    self._insert_ticket_data(req, db, ticket, reporter_id)
  File "C:\Server\Python23\Lib\site-packages\trac\ticket\web_ui.py", line 398, in _insert_ticket_data
    changelog = ticket.get_changelog(db=db)
  File "C:\Server\Python23\Lib\site-packages\trac\ticket\model.py", line 267, in get_changelog
    for t, author, field, oldvalue, newvalue in cursor:
  File "C:\Server\Python23\Lib\site-packages\trac\db.py", line 83, in __iter__
    row = self.cursor.fetchone()
  File "C:\Server\Python23\Lib\site-packages\trac\db.py", line 230, in fetchone
    return row and self._convert_row(row) or None
  File "C:\Server\Python23\Lib\site-packages\trac\db.py", line 226, in _convert_row
    return tuple([(isinstance(v, unicode) and [v.encode('utf-8')] or [v])[0]
UnicodeDecodeError: 'utf8' codec can't decode byte 0x81 in position 28: unexpected code byte

I'm using Trac 0.9, Subversion 1.2.3 together with an Apache 2.0.54 on a Windows System.

Thanks in advance

Horst

PS: Any suggestions for a workaround are also welcome

Attachments (1)

DP1234.doc (39.0 KB ) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by anonymous, 14 years ago

Component: ticket systemsearch system
Resolution: invalid
Status: newclosed

comment:2 by Christian Boos, 14 years ago

Component: search systemticket system
Resolution: invalid
Status: closedreopened

To anonymous: this is not a test system, you just closed a valid ticket.

comment:3 by anonymous, 14 years ago

Python traceback
Traceback (most recent call last):
  File "D:\Python23\Lib\site-packages\trac\web\modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "D:\Python23\Lib\site-packages\trac\web\main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "D:\Python23\Lib\site-packages\trac\web\main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "D:\Python23\Lib\site-packages\trac\ticket\web_ui.py", line 214, in process_request
    self._insert_ticket_data(req, db, ticket, reporter_id)
  File "D:\Python23\Lib\site-packages\trac\ticket\web_ui.py", line 398, in _insert_ticket_data
    changelog = ticket.get_changelog(db=db)
  File "D:\Python23\lib\site-packages\trac\ticket\model.py", line 278, in get_changelog
    "ORDER BY time", (self.id,  str(self.id), self.id))
  File "D:\Python23\Lib\site-packages\trac\db.py", line 219, in execute
    args or [])
  File "D:\Python23\Lib\site-packages\trac\db.py", line 211, in _rollback_on_error
    return function(self, *args, **kwargs)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xb5 in position 13: unexpected code byte

by anonymous, 14 years ago

Attachment: DP1234.doc added

comment:4 by Christian Boos, 14 years ago

Resolution: fixed
Status: reopenedclosed

Duplicate of #1310.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.