Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2321 closed defect (duplicate)

ISO date formatting

Reported by: wilmer@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Right now at most places Trac only displays dates in the sometimes ambiguous MM/DD/YYYY format. I would like to be able to set this to the ISO format (YYYY-MM-DD), since every time I see a different date format I have to guess what is the month and what is the day, not very convenient. :-)

Since this happens at most places where dates are mentioned, I can't really choose a component. BTW, I get the impression that this is something for ClearSilver, not for Trac. Is that right?

Attachments (0)

Change History (4)

comment:1 by wilmer@…, 14 years ago

Ahhh, oops, I found out that this is a locale-setting. I have no idea which locale has the ISO-format, but I'll find a solution now. :-)

Thanks for the great product!

comment:2 by Christian Boos, 14 years ago

I have no idea which locale has the ISO-format

That may be a problem, as I don't think there's one. That's why a special setting for getting the ISO format used by Trac might well be needed.

If there's another solution, I would be also interested to know.

comment:3 by Matthew Good, 14 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #1690.

comment:4 by wilmer@…, 14 years ago

My solution was a little source hack, but that's obviously not very clean. It'll work for me for now. Open source is a great thing. :-D

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.