Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#2312 closed defect (fixed)

Example custom query shows new+assigned, but supposed to show closed

Reported by: Dan <trac@…> Owned by: Christopher Lenz
Priority: low Milestone: 0.9.1
Component: report system Version: 0.9
Severity: minor Keywords: documentation
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

In my project, when clicking the TracQuery link "Active tickets against 0.8", a list of tickets is shown that are not closed, even though the custom query information at the top of the displayed web page correctly has "closed" (only) checked (this is the only filter line displayed). Clicking "update" seems to fix the problem.

Note: My project does not contain a version "0.8" (all versions are removed at the moment). Once I click on "update", the URL no longer contains the "version" field, so I'm wondering if that's the key.

(Also, in general, I'm having a little difficulty selecting the column formatting when using the custom query feature. For instance, determining which columns appear and the order of their appearance.)

Attachments (0)

Change History (4)

comment:1 by Christopher Lenz, 15 years ago

Keywords: documentation added
Milestone: 0.9.1
Owner: changed from daniel to Christopher Lenz
Priority: normallow
Severity: normalminor
Status: newassigned

comment:2 by Matthew Good, 15 years ago

Actually the ticket listing is consistent with the query that is linked, the problem is with the boxes that are checked. The query link has status!=closed, so it should be showing only non-closed tickets. However the checkbox fields don't seem to account for negative expressions.

comment:3 by anonymous, 15 years ago

Thanks for the clarification.

Regarding the column selection, I intuitively tried adding columns by adding a "&fieldname" reference in the query, without any request for comparison, but that didn't do what I expected. Personally, I would think that this would be an intuitive way to add specific columns.

Thanks again for looking into this. I hope that some day I will come up to speed enough with Python and Trac to actually send in updates myself.

comment:4 by Christopher Lenz, 15 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [2586].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.