Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2285 closed defect (fixed)

Stipping whitespace at the beginning of ticket descriptions breaks lists

Reported by: trac@… Owned by: Christopher Lenz
Priority: normal Milestone: 0.9.1
Component: ticket system Version: 0.9
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

If a ticket description begins with a list the first list the space before the first asterisk is stripped breaking the display of the list.

The whitespace is stripped before it makes it into the database; I can update the description manually using the sqlite command-line utility replacing the leading space and the ticket description is again displayed correctly so this isn't a render-time error.

This broke sometime between 0.9b2 and 0.9.

Example description:

 * first list item
 * second list item

…displays as:

  • first list item
    • second list item

Attachments (0)

Change History (3)

comment:1 by trac@…, 14 years ago

Caused by [2373] maybe?

comment:2 by Christopher Lenz, 14 years ago

Milestone: 0.9.1
Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

Yep.

comment:3 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [2580] and [2581].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.