Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2216 closed defect (worksforme)

WebAdmin fails to appear on menu bar

Reported by: tjb@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: devel
Severity: normal Keywords: webadmin
Cc: Branch:
Release Notes:
API Changes:

Description

I have been following the webadmin updates for some time (thanks jonas), and recently set up a new project. I added the relevant TRAC_ADMIN permissions to the user permissions, and expected to see the Admin button appear on the menu bar, as normal. After reverting some changes, and discovering that I had probably been running the original release of WebAdmin all along from the python site-config directory, I can now no longer see the Admin button for any project.

So far as I can tell, my configuration is good, the webadmin egg is is /usr/lib/python2.3/site-packages, and my current version is [2353]

I was unable to find some way of diagnosing where the decision to display the Admin button is made, so could not try to find the cause of the problem

Attachments (0)

Change History (3)

comment:1 by markus, 14 years ago

Same problem here. Trac running on Windows 2000, IIS5.

trac.log says

Trac[loader] DEBUG: Loading plugin tracwebadmin from d:\programme\python23\lib\site-packages\tracwebadmin-0.1dev-py2.3.egg

but the admin button never gets shown (although I've TRAC_ADMIN privileges).

comment:2 by Christopher Lenz, 14 years ago

Resolution: worksforme
Status: newclosed

Please see [2335] and this post to the mailing list.

If you install WebAdmin globally (i.e. setup.py install) instead of deploying the egg to the environments plugins directory, you'll need to enable it explicitly in trac.ini.

For example:

[components]
webadmin.* = enabled

Need to update TracPlugins to document this behavior.

comment:3 by markus, 14 years ago

Yep, that did the trick. Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.