Edgewall Software
Modify

Opened 17 years ago

Closed 16 years ago

Last modified 16 years ago

#2163 closed defect (wontfix)

email notifications not working for anonmous ticket commenters

Reported by: gmk@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.9b2
Severity: normal Keywords: anonymous notification email
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

If anonymous commenter != ticket poster, then they don't get email notifications as they did on my 0.8.4 system.

I tried TICKET_MODIFY and TICKET_APPEND permissions for the anonymous user.

I really liked the feature that anyone adding a comment to a ticket was automatically added to the notification list, and hope that the feature is carried through 0.9x.

Thanks!

Attachments (0)

Change History (7)

comment:1 by Christopher Lenz, 17 years ago

How is an anonymous commenter supposed to get mail notifications? Trac doesn't know the email adress.

Also, This should have nothing to do with permissions.

Can you please explain in more detail?

comment:2 by Emmanuel Blot, 16 years ago

Keywords: anonymous, notification, email → anonymous notification email
Resolution: wontfix
Status: newclosed

Anonymous user cannot receive a notification as he's … anonymous.

About the automatic addition to the CC: list, this enhancement is already been tracked in #2954, hence #1459.

(I'm not sure how to close this ticket: invalid, wontfix or duplicate?)

comment:3 by Christian Boos, 16 years ago

Replying to eblot:

Anonymous user cannot receive a notification as he's … anonymous.

I think that anonymous users can indeed set their E-mail in the Settings and it's then stored in their session (session_attribute table more precisely). If the session_id would be stored in the CC field, they could be notified as well (the CC field should not display what looks like a session id of course, perhaps simply anonymous instead).

I'm not saying that we should necessarily do it, though, only that it would be technically possible.

comment:4 by Emmanuel Blot, 16 years ago

I believe that this should be considered as a bug: an anonymous user should not be able to change the "settings".

I don't know whether it is possible for now?

comment:5 by Christian Boos, 16 years ago

No, it's certainly not a bug, it's by design.

You can have a session (i.e. storage of your browsing preferences, your last ticket query and such), without having to log in.

It's rather the fact that currently the Settings doesn't show you or let you manipulate your session information that could be considered a bug :)

comment:6 by Emmanuel Blot, 16 years ago

I find this feature quite disturbing:

Which address the anonymous user would be tied to?
If I understand it right, Trac can store an unlimited anonymous sessions, as long as session ids are unique. However, if anonymous user was to be notified, from which session the login will be resolved to an email address?

comment:7 by Christian Boos, 16 years ago

That's why I said in my first comment that in the case of anonymous, the session id itself should be stored in the CC field (but shouldn't be displayed; what can be displayed could be, e.g. "+ 3 anonymous users").

Again, not necessarily a good idea, only a possibility.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.