Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2106 closed defect (fixed)

lighttpd+FastCGI errors

Reported by: Enderson Maia (enderson@… Owned by: Jonas Borgström
Priority: normal Milestone: 0.9
Component: general Version: 0.9b2
Severity: major Keywords: fastcgi lighttpd fcgi.py
Cc: enderson@…, vyt@… Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

Here is the lighttpd.log while I'm using Trac.

====8<====
2005-09-21 19:23:28: (mod_fastcgi.c.2108) FastCGI-stderr:  
2005-09-21 19:23:28: (mod_fastcgi.c.2108) FastCGI-stderr: Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/_fcgi.py", line 567, in run
    protocolStatus, appStatus = self.server.handler(self)
TypeError: unpack non-sequence
 
2005-09-21 19:23:28: (mod_fastcgi.c.2108) FastCGI-stderr:  
2005-09-21 19:23:40: (mod_fastcgi.c.2108) FastCGI-stderr: Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/_fcgi.py", line 567, in run
    protocolStatus, appStatus = self.server.handler(self)
TypeError: unpack non-sequence
 
2005-09-21 19:23:40: (mod_fastcgi.c.2108) FastCGI-stderr:  
2005-09-21 19:23:42: (mod_fastcgi.c.2108) FastCGI-stderr: Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/_fcgi.py", line 567, in run
    protocolStatus, appStatus = self.server.handler(self)
TypeError: unpack non-sequence
 
2005-09-21 19:23:42: (mod_fastcgi.c.2108) FastCGI-stderr: 
====8<====

I can't do anything but browse the site, can't add/edit tickets/wikis.

Attachments (0)

Change History (10)

comment:1 by Enderson Maia, 14 years ago

Cc: enderson@… added

Forgot to mention some program verions

python-2.3.5 lighttpd-1.3.16

If you need more details, just ask.

comment:2 by pierre.francois@…, 14 years ago

Severity: normalmajor
Version: 0.9b10.9b2

I am having the same problem, but with trac-0.9b2 and python 2.4.1. The rest is the same as mentionned above.

comment:3 by aturk@…, 14 years ago

I have the same problem, but with FastCGI 2.4.0/python 2.3.5/Apache 1.3.33

comment:4 by aturk@…, 14 years ago

also, I am running RH Linux 8.0

comment:5 by anonymous, 14 years ago

Milestone: 0.9

comment:6 by Jonas Borgström, 14 years ago

Status: newassigned

Can you guys test [2405] and see if that fixes this problem? We didn't return correct (or any at all) protocol status codes from out fast_cgi handler.

comment:7 by Jonas Borgström, 14 years ago

#2252 is a duplicate of this issue.

comment:8 by Christopher Lenz, 14 years ago

Description: modified (diff)
Summary: lighttpd+FasCGI errorslighttpd+FastCGI errors

comment:9 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Marking this as fixed. If you're still seeing the problem, please reopen this ticket.

comment:10 by anonymous, 14 years ago

Cc: vyt@… added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.