Edgewall Software
Modify

Opened 14 years ago

Last modified 5 years ago

#2064 new defect

Timeline WikiFormatting mis-parses WikiLinks with aliases.

Reported by: chandlerc@… Owned by:
Priority: normal Milestone: topic-wikiengine
Component: wiki system Version: devel
Severity: major Keywords: wiki_to_oneliner shorten
Cc: Branch:
Release Notes:
API Changes:

Description

In the timeline, the snippet of text that supports WikiFormatting will mis-parse a link of the format: [wiki:foobar foo].

If the literal text "[wiki:foobar foo]" is longer than the line permits, it will produce:

Blah blah blah [wiki:foobar

when it could easily fit

Blah blah blah foo

into the line.

Attachments (0)

Change History (14)

comment:1 by chandlerc@…, 14 years ago

This should in all likelihood be wrapped up by a more general solution to correctly handle displaying a snippet of WikiFormatted text correctly, including both TracLinks, pre-formatted code blocks, WikiProcessors, etc.

My 2cents… =]

-cc

comment:2 by Christian Boos, 14 years ago

Component: timelinewiki
Keywords: wiki_to_oneliner shorten added; WikiFormatting timeline removed

One solution would be to have a parser generating wiki formatting elements, and the consumer (here, an HTML formatter) should stop as soon as it produced "enough" text.

comment:3 by Christian Boos, 14 years ago

Milestone: 1.0

comment:4 by Christian Boos, 13 years ago

See also #4484, which was marked as duplicate.

comment:5 by Christian Boos, 13 years ago

Milestone: 1.00.11

comment:6 by Christian Boos, 13 years ago

Owner: changed from Jonas Borgström to Christian Boos

comment:7 by Christian Boos, 13 years ago

Milestone: 0.110.12

WikiEngine refactoring and related fixes postponed.

comment:8 by Christian Boos, 11 years ago

Besides the timeline, the PageOutline macro suffers from the same problem (see #5059).

comment:9 by anonymous, 10 years ago

Resolution: fixed
Status: newclosed

comment:10 by Remy Blank, 10 years ago

Resolution: fixed
Status: closedreopened

Please don't change the status of a ticket without an explanation (especially as anonymous).

comment:11 by Christian Boos, 10 years ago

Milestone: next-major-0.1X0.13
Severity: normalmajor

comment:12 by Christian Boos, 9 years ago

Milestone: 0.130.14-wikiengine

comment:13 by Christian Boos, 8 years ago

#10341 was closed as duplicate of this ticket.

comment:14 by Ryan J Ollos, 5 years ago

Owner: Christian Boos removed
Status: reopenednew

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned. Next status will be 'new'.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.