Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2032 closed enhancement (fixed)

Trac browser doesn't allow direct viewing of .mm files

Reported by: jack@… Owned by: Christopher Lenz
Priority: normal Milestone: 0.9
Component: version control/browser Version: 0.8.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

The .mm extension is somewhat common in Mac programming nowadays; It's a source code file that can contain a mix of c++ and objective-c. Neither 0.8.4 (in source:tags/trac-0.8.4/trac/Mimeview.py) nor the trunk (in source:trunk/trac/mimeview/api.py) include it in their MIME_MAP list. It should probably be in there, just a duplicate of the definition for .m files, so that these files can be viewed in the browser

Attachments (0)

Change History (5)

comment:1 by dna, 14 years ago

Use the svn:property to set the mimetype to:

text/x-objc

comment:2 by Christian Boos, 14 years ago

I wonder if such kind of configuration couldn't be done using the Wiki: for the InterWiki configuration, it's common to have an editable list of InterWiki prefix and their corresponding address.

It could be interesting to have a MimeMap page which would do the same for files suffixes and their associated types.

comment:3 by Christopher Lenz, 14 years ago

cboos, that would make the mimeviewer sub-system depend on the wiki sub-system, which I don't think is a good idea.

comment:4 by Christopher Lenz, 14 years ago

Milestone: 0.9
Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

comment:5 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [2212].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.