Edgewall Software
Modify

Opened 17 years ago

Closed 16 years ago

#2031 closed defect (wontfix)

RSS to have a param html=on/off so it removes <p> and such stuff that bots (IRC, Jabber) do not understand

Reported by: Nikos Kouremenos Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: 0.8.4
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

subj says it all.

also the params (all of them) should be documents in TracRss page

Attachments (0)

Change History (2)

comment:1 by karltk@…, 16 years ago

The embedded HTML without proper namespaces confuses a lot of feed readers. Also it prevents the feed from validating properly.

As an example, try sending the RSS feed for http://projects.edgewall.com/trac/timeline to http://feedvalidator.org; you will see that the Trac RSS feed on the Trac site itself doesn't even validate:)

comment:2 by Christian Boos, 16 years ago

Resolution: wontfix
Status: newclosed

The Trac feed doesn't validate right now because it's still running an older version of Trac. The problem is now fixed in the 0.9-stable branch (see r2829), which will be available for the upcoming 0.9.4 release.

Besides, closer to the subject of this ticket, it was decided that we don't want to offer an option to leave the HTML out of the RSS feed. See

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.