Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 5 years ago

#2021 closed enhancement (fixed)

Add "New Ticket" message that can be used to warn people it is not a test or demo site.

Reported by: anonymous Owned by: Christopher Lenz
Priority: highest Milestone: 0.9
Component: ticket system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

A paramter in the ini should be created to provide a message on the Create New Ticket page.

On the projects.edgewall.com/trac site, this message should be a warning that it is not a test or demo site. The warning should include a link to a demo site.

I think people must stumble on the Create New Ticket and don't know better. If people had an opportunity to go to a demo site, I think most would.

Attachments (1)

2021-fix.patch (3.4 KB ) - added by Christian Boos 14 years ago.
Adds a new default template (site_newticket_policy.cs) and refactored the code to make it easier to add new default templates in the future.

Download all attachments as: .zip

Change History (10)

comment:1 by anonymous, 14 years ago

I think this is a duplicate of #1961.

comment:2 by anonymous, 14 years ago

It aims to solve the same problem as #1961, although in a more configurable manner.

comment:3 by Christian Boos, 14 years ago

Owner: changed from Jonas Borgström to Christian Boos
Priority: normalhighest
Status: newassigned
Version: 0.8.4devel

I think that's a good idea.

What about something like:

[ticket]
new_ticket_policy = "Please check that there isn't already a bug or feature request similar to the one you're about to create. etc."

comment:4 by Emmanuel Blot, 14 years ago

There are three (IMHO too many) sources for strings displayed to users:

  1. ClearSilver templates
  2. Python code
  3. trac.ini

I would prefer the "template" way: it would give a better leverage to customize the new ticket page. We already have site_header.cs and site_footer.cs, why not a site_newticket.cs ?

comment:5 by Christian Boos, 14 years ago

Ah, didn't think about that. Yes, a site_newticket.cs seems to be even a better idea.

(the .ini file is really not appropriate for putting multi-line content, that was a "pis aller" :) )

by Christian Boos, 14 years ago

Attachment: 2021-fix.patch added

Adds a new default template (site_newticket_policy.cs) and refactored the code to make it easier to add new default templates in the future.

comment:6 by Christian Boos, 14 years ago

Milestone: 0.9

The proposed patch would be useful to have on p.e.c, along with a customized site_newticket_policy.cs informing people that This is not a test system

comment:7 by Christopher Lenz, 14 years ago

Owner: changed from Christian Boos to Christopher Lenz
Status: assignednew

I don't like requiring an upgrade just to put site-specific template in place. Personally, I remove all the site_*.cs files that I don't use.

I've got a similar change in the queue that doesn't have this problem, and will check it in.

comment:8 by Christopher Lenz, 14 years ago

Status: newassigned

comment:9 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Implemented in [2272].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.