Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#1793 closed enhancement (duplicate)

Finer grained access control over wiki pages

Reported by: davidmeggy@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: wiki system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I addition to the settings in trac-admin it would be useful to add a page owner and permission lists to indivual pages for read and write.

Attachments (0)

Change History (4)

comment:1 by Matthew Good, 17 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #654

comment:2 by anonymous, 17 years ago

In order to keep fine-grained access control manageable, we would need to be able to specify access permissions for SubWikis. For example, if we specify that Gabrielle is allowed to edit SomeStuff, then she should also be allowed to edit SomeStuff/SomeDetails and SomeStuff/MoreDetails, and even SomeStuff/MoreDetails/ReallyDetailedStuff, without having to explicitly add edit permission for all of those pages.

comment:3 by markus, 17 years ago

That's a good idea, indeed. I'm voting for reopening this ticket! :-p

comment:4 by Matthew Good, 17 years ago

This is a duplicate ticket. If you want to add to the discussion, please do so on the original ticket to avoid forking.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.