Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#1712 closed enhancement (duplicate)

Allow Excel and Word files be viewed in "Browse Source"

Reported by: cmgreen@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/browser Version: 0.8.4
Severity: normal Keywords: word excel
Cc: mjlucas@… Branch:
Release Notes:
API Changes:

Description

The project I'm using trac for has lots of word and excel documents in it that store various aspects of our project. Using xlhtml and wvware, I spit out either text or html fragments that is usable for viewing word docs. In the future, I'd like to support diffs between these word/excel documents.

I've worked on trac 0.8.4 and I noticed that this functionality is acts differently on the trunk. Hopefully, this will be able to move forward without much of an issue.

In File.py, I had to make some changes and pass both a "utf8" and a "raw" version of read data to the Mimeviewer api. This was necessary because the utf8 encoding broke the word document; The image plugin seems to ignore the data and work around the issue by grabbing the RAW data.

Attachments (2)

word.excel.diff (8.8 KB ) - added by cmgreen@… 14 years ago.
Allow Trac to use wvhtml and xlhtml to view word and excel files
word.excel.2.diff (8.8 KB ) - added by cmgreen@… 14 years ago.
Revised handling of excel files

Download all attachments as: .zip

Change History (10)

by cmgreen@…, 14 years ago

Attachment: word.excel.diff added

Allow Trac to use wvhtml and xlhtml to view word and excel files

by cmgreen@…, 14 years ago

Attachment: word.excel.2.diff added

Revised handling of excel files

comment:1 by Matthew Good, 14 years ago

The 0.8 branch is only being updated for vital bugfixes. Patches for new features should be made against the trunk.

comment:2 by mjlucas@…, 14 years ago

Has anything been done about this bug? It is still listed as new and linked against a old version.

It would be a useful feature for Trac since a lot of documentation of projects is still written in Word.

comment:3 by anonymous, 14 years ago

Cc: mjlucas@… added

comment:4 by Emmanuel Blot, 14 years ago

IMHO, this bug should be closed as "wontfix": this feature (support for platform-specific files) would better be implemented as a plugin.

comment:5 by Matthew Good, 13 years ago

#2254 has been marked as a duplicate.

comment:6 by sid, 13 years ago

Agreeing with eblot - seems perfect for a plugin (and a wontfix for this ticket).

in reply to:  description comment:7 by Christian Boos, 13 years ago

Resolution: duplicate
Status: newclosed

Replying to cmgreen@uab.edu:

… In the future, I'd like to support diffs between these word/excel documents.

Yes, this is something we should definitely have, pluggable diff viewers. See #53.

Replying to sid:

Agreeing with eblot - seems perfect for a plugin

ok for a plugin in this case, but the appropriate interfaces are not yet finalized (see #3332)

(and a wontfix for this ticket).

Rather a duplicate of #3332 and #53.

comment:8 by anonymous, 12 years ago

has somebody written a plugin for this?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.