Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#1413 closed defect (duplicate)

Updating a removed component for a ticket fails

Reported by: jason@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I removed some components that many tickets were assigned to. Later, when I tried to edit the ticket to change the component to the new component, version 0.8 of Trac fails with this backtrace:

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 525, in cgi_start
    real_cgi_start()
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 520, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request
    module.run()
  File "/usr/lib/python2.3/site-packages/trac/Module.py", line 44, in run
    self.render()
  File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 444, in render
    self.save_changes (id)
  File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 372, in save_changes
    when=now)
  File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 139, in save_changes
    old_owner = cursor.fetchone()[0]
TypeError: unsubscriptable object

Attachments (0)

Change History (1)

comment:1 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1045. Fixed in 0.8.1.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.