Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#1398 closed defect (duplicate)

Add support for multiple projects in the same SVN repository

Reported by: tomek@… Owned by: daniel
Priority: normal Milestone:
Component: project Version: 0.8.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

At the moment it appears that Trac uses one SVN repository per project. There is no way that I can find to specify that Trac should only look at a certain subdirectory of the SVN repository. I have many projects in one SVN repository. The Timeline in particular becomes not very useful when I see every change for every project.

I should be able to specify full SVN URL for every Trac Environment and all operations should be limited to that path (eg Timeline, Browse Source).

Attachments (0)

Change History (3)

comment:1 by Matthew Good, 15 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #586

However, if you are interested, the online Subversion book discusses splitting an svn repository.

comment:2 by tomek@…, 15 years ago

Thanks for the tip on splitting a repository. I really don't want to do this though. It seems like a very ugly workaround. I think I'll wait until Trac has proper support for specifying repository paths. Hopefully it won't be too long :-)

comment:3 by Matthew Good, 15 years ago

Based on cmlenz's comments on #586, this currently works in the development version, and should be available in the next release:

As a matter of fact, we already have some support for repository subsets as of [1413]. I.e., instead of having to specify the base path of the repository in TracIni, you can specify a path inside the repos (for example /var/svn/myrepos/project/subproejct, where /var/svn/myrepos is the path to the repository).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.