Edgewall Software
Modify

Opened 7 weeks ago

Closed 6 weeks ago

#13240 closed defect (fixed)

AppVeyor: 13 errors due to TracError: Cannot load Python bindings for SQLite

Reported by: Jun Omae Owned by: Jun Omae
Priority: normal Milestone: 1.0.20
Component: general Version:
Severity: normal Keywords: appveyor
Cc: Branch:
Release Notes:

Fixed failures to load Python bindings for SQLite on Miniconda Python in AppVeyor.

API Changes:

Description

https://ci.appveyor.com/project/edgewall-org/trac/builds/29943185

======================================================================
ERROR: test_abs_href (trac.tests.env.EnvironmentTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\projects\trac\trac\tests\env.py", line 61, in setUp
    self.env = Environment(env_path, create=True)
  File "C:\projects\trac\trac\core.py", line 124, in __call__
    self.__init__(*args, **kwargs)
  File "C:\projects\trac\trac\env.py", line 289, in __init__
    self.create(options)
  File "C:\projects\trac\trac\env.py", line 612, in create
    DatabaseManager(self).init_db()
  File "C:\projects\trac\trac\db\api.py", line 250, in init_db
    connector, args = self.get_connector()
  File "C:\projects\trac\trac\db\api.py", line 339, in get_connector
    raise TracError(connector.error)
TracError: Cannot load Python bindings for SQLite
...
Ran 1915 tests in 559.667s
FAILED (errors=13)
make: *** [Makefile:445: unit-test] Error 1

Attachments (0)

Change History (2)

comment:1 by Jun Omae, 7 weeks ago

Owner: set to Jun Omae
Release Notes: modified (diff)
Status: newassigned

Proposed changes in [6a274bf31/jomae.git] (jomae.git@t13240).

The issue is solved by adding $miniconda/Library/bin to PATH. I guess that location of sqlite3.dll has been changed since recent miniconda package.

Build results: https://ci.appveyor.com/project/jun66j5/trac/builds/29991176

Last edited 7 weeks ago by Jun Omae (previous) (diff)

comment:2 by Jun Omae, 6 weeks ago

Resolution: fixed
Status: assignedclosed

Committed and merged in [17227-17230].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.