Edgewall Software
Modify

Opened 13 months ago

Closed 13 months ago

Last modified 4 months ago

#13195 closed defect (fixed)

Problem with macros that load CSS / JS

Reported by: anonymous Owned by: Jun Omae
Priority: highest Milestone: 1.5.1
Component: rendering Version:
Severity: normal Keywords: jinja2
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Fixed regressions in r17093.

Description

There seems to be a problem in after r17093:

To reproduce create a ticket or wiki page containing a macro that loads additional CSS or Javascript, for example [[RepositoryIndex(format=table)]]. Before the change this loads CSS to show folder icons and so on. After the change it does not. Other macros that load JS also don't work anymore.

Attachments (0)

Change History (10)

comment:1 by anonymous, 13 months ago

It seems the problem is that these lines were deleted in r17093. Were they maybe removed by mistake? Or the simpler way hinted at in the comment was not added, or is not working?

comment:2 by Jun Omae, 13 months ago

Keywords: jinja2 added
Milestone: 1.5.1

comment:3 by anonymous, 13 months ago

Priority: normalhighest

Regression that breaks built-in functionality.

comment:4 by anonymous, 13 months ago

[[Workflow]] is another built-in macro broken by this. The Javascript does not get loaded.

comment:5 by Jun Omae, 13 months ago

Proposed changes in [999f08f55/jomae.git] (jomae.git@t13195), with unit tests.

comment:6 by Ryan J Ollos, 13 months ago

Thank you for fixing.

comment:7 by anonymous, 13 months ago

Great thanks!

comment:8 by Jun Omae, 13 months ago

Owner: set to Jun Omae
Release Notes: modified (diff)
Status: newassigned

Committed in [17123].

comment:9 by Jun Omae, 13 months ago

Resolution: fixed
Status: assignedclosed

comment:10 by Ryan J Ollos, 4 months ago

Internal Changes: modified (diff)
Release Notes: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.