Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#1297 closed defect (wontfix)

Ticket with empty description is acceptable

Reported by: shad Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: trivial Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Ticket without description field is acceptable.

Attachments (0)

Change History (3)

comment:1 by shad, 15 years ago

The fix is trivial:

diff -ru trac.old/trunk/trac/Ticket.py trac/trunk/trac/Ticket.py
--- trac.old/trunk/trac/Ticket.py       2005-03-14 01:05:39.000000000 +0300
+++ trac/trunk/trac/Ticket.py   2005-03-14 23:14:27.000000000 +0300
@@ -284,6 +284,8 @@
     def create_ticket(self, req):
         if not req.args.get('summary'):
             raise util.TracError('Tickets must contain a summary.')
+        if not req.args.get('description'):
+            raise util.TracError('Tickets must contain a description.')
 
         ticket = Ticket()
         ticket.populate(req.args)

comment:2 by Christopher Lenz, 15 years ago

Resolution: wontfix
Status: newclosed

That is by design. Yes, you can create a ticket without a description. So what?

I could imagine a config option for making the description a required field, but it'll not become default behavior.

comment:3 by shad, 15 years ago

As I can see in my project, all tickets with empty description field are saved only by mistake.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.