Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

#1282 closed defect (fixed)

Settings page submissions tries to submit to unknown host.

Reported by: aashley@… Owned by: Christopher Lenz
Priority: normal Milestone: 0.8.3
Component: web frontend/mod_python Version: 0.8.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When submitting the Settings form it redirects to an unknown host. The action parameter for the for the form is set to "settings/" which mozilla firefox interperates as a new host.

This problem is I suspect related to the fix for #1143

Attachments (0)

Change History (5)

comment:1 by aashley@…, 15 years ago

Okay finally got enough time to investigate this problem further. It is related to the fix for #1143 which made sure that the forms had at least / for the action setting. While this worked for things like the modules editing it does work for things where the action url is set in the template file.

The code in the html templates has the action set for ie the settings page to action="<?cs var:cgi_location?>/settings/".

So with the fix for #1143 we end up with settings/ being the submit location which is interperated as a new server.

comment:2 by Christopher Lenz, 14 years ago

Component: generalmod_python frontend
Owner: changed from Jonas Borgström to Christopher Lenz

#1627 has been marked as duplicate of this ticket.

comment:3 by Christopher Lenz, 14 years ago

Status: newassigned

comment:4 by Christopher Lenz, 14 years ago

Milestone: 0.8.3

Note that this is fixed in trunk, but not in 0.8-stable.

comment:5 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [1794].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.