Edgewall Software
Modify

Opened 3 years ago

Closed 2 years ago

#12672 closed defect (worksforme)

tracopt.perm.tests.authz_policy.test_suite failures on trunk (Windows)

Reported by: Christian Boos Owned by:
Priority: normal Milestone:
Component: general Version: 1.3dev
Severity: normal Keywords: authz_policy
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

Not sure if it's related to one of the recent tickets relative to the authz changes (#12637, #12649 maybe?). In doubt, I created a new ticket.

I get these 3 errors on trunk (r15375):

======================================================================
FAIL: test_non_default_repository (tracopt.perm.tests.authz_policy.AuthzPolicyTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\Trac\repos\trunk\tracopt\perm\tests\authz_policy.py", line 158, in test_non_default_repository
    self.assertTrue(repos.is_viewable(self.get_perm(u'A☼non')))
AssertionError: False is not true

======================================================================
FAIL: test_resource_without_id (tracopt.perm.tests.authz_policy.AuthzPolicyTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\Trac\repos\trunk\tracopt\perm\tests\authz_policy.py", line 141, in test_resource_without_id
    self.assertIn('TICKET_VIEW', perm('ticket', 43))
AssertionError: 'TICKET_VIEW' not found in <trac.perm.PermissionCache object at 0x0000000016255B40>

======================================================================
FAIL: test_unicode_username (tracopt.perm.tests.authz_policy.AuthzPolicyTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\Trac\repos\trunk\tracopt\perm\tests\authz_policy.py", line 105, in test_unicode_username
    self.check_permission('WIKI_VIEW', u'A☼non', resource, perm))
AssertionError: False is not true

----------------------------------------------------------------------
Ran 2222 tests in 182.375s

FAILED (failures=3)

Only with Python 2.7.13 on Windows x64 when running the full test suite.

Executing these tests in isolation, it's fine:

python  setup.py -q test -s tracopt.perm.tests.authz_policy.test_suite
..............
----------------------------------------------------------------------
Ran 14 tests in 0.201s

With Python 2.7.9 WSL, it's fine.

I give a few more details on my system, as it seems the error doesn't happen on AppVeyor:

Python: /c/Dev/Python2713x64/python

  Package        Version
  -----------------------------------------------------------------------------------------------
  Python       : 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 2016, 20:53:40) [MSC v.1500 64 bit (AMD64)]
  Setuptools   : 28.8.0
  Genshi       : 0.7 (with speedups)
  Babel        : 2.3.4
  sqlite3      : 2.6.0 (3.8.11)
  PySqlite     : not installed
  MySQLdb      : not installed
  Psycopg2     : not installed
  SVN bindings : 1.9.3 (r1718519)
  Mercurial    : 3.9-rc+16-d3df009ab117
  Pygments     : 2.1.3
  Textile      : not installed
  Pytz         : 2016.10
  Docutils     : 0.13.1
  Twill        : 0.9
  LXML         : 3.7.2
  coverage     : not installed
  figleaf      : not installed

...
  TRAC_TEST_DB_URI=
...

External dependencies:
  Git version: git version 2.10.0.windows.1
  Subversion version: 1.8.10

Attachments (0)

Change History (4)

comment:1 by Christian Boos, 3 years ago

Description: modified (diff)

comment:2 by Ryan J Ollos, 3 years ago

I can't reproduced on Windows 7 x64 with Python 2.7.13 32-bit or 64-bit and:

  Package        Version
  -----------------------------------------------------------------------------------------------
  Python       : 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 2016, 20:42:59) [MSC v.1500 32 bit (Intel)]
  Setuptools   : 34.0.2
  Genshi       : 0.7 (without speedups)
  Babel        : 2.3.4
  sqlite3      : 2.6.0 (3.8.11)
  PySqlite     : not installed
  MySQLdb      : not installed
  Psycopg2     : 2.6.2 (dt dec pq3 ext)
  SVN bindings : not installed
  Mercurial    : 4.0.2
  Pygments     : 2.2.0
  Textile      : 2.3.6
  Pytz         : 2016.10
  Docutils     : 0.13.1
  Twill        : 0.9
  LXML         : 3.7.2
  coverage     : 4.3.4
  figleaf      : not installed
Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:3 by Ryan J Ollos, 3 years ago

Milestone: 1.3.21.3.3

comment:4 by Ryan J Ollos, 2 years ago

Milestone: 1.3.3
Resolution: worksforme
Status: newclosed

Let me know if you have more details and can still reproduce with latest revision of trunk.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.