Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12665 closed defect (fixed)

TracAdmin changeset added / modified have incorrect return code when repository or changeset invalid

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.0.14
Component: version control Version:
Severity: normal Keywords: trac-admin
Cc: massimo.b@… Branch:
Release Notes:

Fixed changeset added and changeset modified TracAdmin commands having incorrect return code and printing to stdout rather than stderr.

API Changes:
Internal Changes:

Description

Reported in gmessage:trac-users:SgBiq1KlrY4/cWzuCJfCAwAJ, trac-admin $env changeset added <repos> <changeset> and trac-admin $env changeset modified <repos> <changeset> don't set return code 2 and print to stderr when <repos> or <changeset> invalid.

Attachments (0)

Change History (4)

comment:1 by Ryan J Ollos, 4 years ago

The issue is due to the implementation of #11775.

comment:2 by Ryan J Ollos, 4 years ago

Resolution: fixed
Status: assignedclosed

Committed to 1.0-stable in r15364, merged to 1.2-stable in r15365, merged to trunk in r15366.

I'll improve test coverage as part of #12667.

comment:3 by Ryan J Ollos, 4 years ago

Release Notes: modified (diff)

comment:4 by Massimo <massimo.b@…>, 4 years ago

Cc: massimo.b@… added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.